Bug 76747 - [GTK] Scrollbars do not respect the has-backward-stepper and has-forward-stepper properties
: [GTK] Scrollbars do not respect the has-backward-stepper and has-forward-step...
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Martin Robinson
https://bugs.webkit.org/query.cgi?for...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-20 15:11 PST by Martin Robinson
Modified: 2012-01-23 16:54 PST (History)
4 users (show)

See Also:


Attachments
Patch (7.89 KB, patch)
2012-01-20 15:15 PST, Martin Robinson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2012-01-20 15:11:01 PST
Ths is particularly noticeable in the most recent version of Adwaita, which doesn't have scrollbars steppers.  All WebCore rendered scrollbars have steppers when they shouldn't.
Comment 1 Martin Robinson 2012-01-20 15:15:00 PST
Created attachment 123389 [details]
Patch
Comment 2 Carlos Garcia Campos 2012-01-22 23:59:15 PST
Comment on attachment 123389 [details]
Patch

I think this is not a bug, but a feature! I like the steppers :-D Patch looks good to me. Thanks!
Comment 3 Gustavo Noronha (kov) 2012-01-23 09:21:52 PST
Comment on attachment 123389 [details]
Patch

Looks good to me as well =)
Comment 4 WebKit Review Bot 2012-01-23 16:54:20 PST
Comment on attachment 123389 [details]
Patch

Clearing flags on attachment: 123389

Committed r105660: <http://trac.webkit.org/changeset/105660>
Comment 5 WebKit Review Bot 2012-01-23 16:54:24 PST
All reviewed patches have been landed.  Closing bug.