Bug 7528 - REGRESSION: GIF animation speeds are wrong on a page with many animated GIFs
Summary: REGRESSION: GIF animation speeds are wrong on a page with many animated GIFs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Darin Adler
URL: http://www.deviantart.com/deviation/8...
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2006-02-28 19:54 PST by crastinator
Modified: 2006-03-08 01:52 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description crastinator 2006-02-28 19:54:04 PST
www.deviantart.com
I'm pretty sure that it applies to other sites that have .gif animations but this is the only instance where I've seen it occur. The problem is most prominant in the .gif file showing a masked character walking across a cartoony setting.

The gif address: http://a.deviantart.com/avatars/s/m/smashmethod.gif
Using nightly build WebKit-SVN-r13030 on Tiger 10.4.5
Comment 1 crastinator 2006-02-28 20:07:26 PST
Something strange. When I open the .gif file in a separate window (via right click contextual menu on page:http://www.deviantart.com/deviation/8355644/ on the .gif file in question), it runs at normal speed. I just did this using build r13060
Comment 2 Alexey Proskuryakov 2006-02-28 21:53:46 PST
Also, one of the GIFs on this page runs slower than before. In all cases, the old results appear to match Firefox.

ToT takes almost 100% CPU on this page.