Bug 75266 - Function should handle wrapping/unwrapping RefPtr and PassRefPtr
Summary: Function should handle wrapping/unwrapping RefPtr and PassRefPtr
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-27 13:16 PST by Anders Carlsson
Modified: 2011-12-27 13:40 PST (History)
1 user (show)

See Also:


Attachments
Patch (7.64 KB, patch)
2011-12-27 13:21 PST, Anders Carlsson
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2011-12-27 13:16:58 PST
Function should handle wrapping/unwrapping RefPtr and PassRefPtr
Comment 1 Anders Carlsson 2011-12-27 13:21:25 PST
Created attachment 120614 [details]
Patch
Comment 2 WebKit Review Bot 2011-12-27 13:25:53 PST
Attachment 120614 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Tools/TestWebKitAPI/Tests/WTF/Functional.cpp:186:  Extra space before ( in function call  [whitespace/parens] [4]
Tools/TestWebKitAPI/Tests/WTF/Functional.cpp:189:  Extra space before ( in function call  [whitespace/parens] [4]
Tools/TestWebKitAPI/Tests/WTF/Functional.cpp:193:  Extra space before ( in function call  [whitespace/parens] [4]
Source/JavaScriptCore/wtf/Functional.h:216:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 4 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Sam Weinig 2011-12-27 13:26:53 PST
Comment on attachment 120614 [details]
Patch

Looks good.  You might want to add tests for the wrap/unwrap functions directly, but this looks fine.
Comment 4 Anders Carlsson 2011-12-27 13:40:26 PST
Committed r103726: <http://trac.webkit.org/changeset/103726>