Bug 7440 - Floats not positioned correctly
Summary: Floats not positioned correctly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://etuovi.com
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-23 21:25 PST by Antti Koivisto
Modified: 2006-02-24 20:26 PST (History)
0 users

See Also:


Attachments
testcase (388 bytes, text/html)
2006-02-23 21:28 PST, Antti Koivisto
no flags Details
patch (938 bytes, patch)
2006-02-23 22:33 PST, Antti Koivisto
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2006-02-23 21:25:15 PST
In etuovi.com the password entry field is not visible and there is overlapping text under "Oma etuovi" headline. The problem is with float positioning.
Comment 1 Antti Koivisto 2006-02-23 21:28:14 PST
Created attachment 6693 [details]
testcase
Comment 2 Antti Koivisto 2006-02-23 22:33:06 PST
Created attachment 6696 [details]
patch

Correct the use of QPtrList in RenderBlock::positionNewFloats(). In case all list entries needed positioning, the list current() pointer would get cleared and only the first entry would actually be positioned.
Comment 3 Dave Hyatt 2006-02-24 00:13:15 PST
Comment on attachment 6696 [details]
patch

r=me
Comment 4 Darin Adler 2006-02-24 08:23:30 PST
To land, we need to turn the test case into a layout test and write ChangeLog.
Comment 5 Antti Koivisto 2006-02-24 09:48:12 PST
(In reply to comment #4)
> To land, we need to turn the test case into a layout test and write ChangeLog.
> 

I can do that to test my new commit powers. Anything I need to know about the process?