Bug 74129 - SnowLeopard: ends of scrollbar thumbs drawn incorrectly
Summary: SnowLeopard: ends of scrollbar thumbs drawn incorrectly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 74128 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-08 14:39 PST by Mehmet
Modified: 2012-04-05 22:30 PDT (History)
6 users (show)

See Also:


Attachments
Screenshot (66.26 KB, image/png)
2011-12-08 14:39 PST, Mehmet
no flags Details
Webkit Scrollbar Bug (289.84 KB, image/png)
2011-12-08 14:42 PST, Mehmet
no flags Details
Screenshot (75.80 KB, image/png)
2012-01-13 10:42 PST, Mehmet
no flags Details
patch (4.08 KB, patch)
2012-04-05 14:46 PDT, Adele Peterson
bdakin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mehmet 2011-12-08 14:39:27 PST
Created attachment 118473 [details]
Screenshot

Version 5.1.2 (6534.52.7, r102332)
MacOS 10.6.8

What steps will reproduce the problem?
1. Visit a page
2. Shrink the window so that scrollbars appear
3. Take a look at the scrollbar at the bottom

Expected: No glitches.

Actual: There are glitches.



***Screenshot attached***

Thanks and regards
Mehmet
Comment 1 Mehmet 2011-12-08 14:42:20 PST
Created attachment 118474 [details]
Webkit Scrollbar Bug
Comment 2 Mehmet 2011-12-08 14:43:43 PST
*** Bug 74128 has been marked as a duplicate of this bug. ***
Comment 3 Mehmet 2011-12-21 17:17:41 PST
Please, if possible, this should be a blocker for the next Safari Stable.
Comment 4 Mehmet 2012-01-13 10:42:52 PST
Created attachment 122454 [details]
Screenshot

What I noticed is, that the scrollbar is drawn correctly on youtube.com. But it is still broken e.g. on bugs.webkit.org.
Screenshot attached.
Comment 5 Mehmet 2012-03-12 16:40:39 PDT
Hi.

I can't believe that this annoying visual UI issue is now landed on Safari stable Version 5.1.4 (6534.54.16) :-(

This issue is known since 3 months and it has still the status unconfirmed.

There was so much time to fix this issue :-(
Comment 6 Alexey Proskuryakov 2012-03-12 16:46:00 PDT
Are you saying that this worked in Safari 5.1.2, and broke in 5.1.4?

In the future, please explicitly mention when something is a regression. From the report, it sounded like this was a long-standing problem, still occurring in nightly builds.
Comment 7 Mehmet 2012-03-12 16:54:44 PDT
Hi Alexey,

sorry for the misunderstanding and my poor description. But when I run the latest Webkit, the actual Safari version is also mentioned in the 'About Safari Box'.

Yes, it worked well in official Safari 5.1.2 and it is now broken in official 5.1.4 on Mac OS 10.6.8.

If you need more information, please let me know.

Regards
Mehmet
Comment 8 Radar WebKit Bug Importer 2012-03-27 15:33:28 PDT
<rdar://problem/11133179>
Comment 9 Adele Peterson 2012-04-04 17:31:20 PDT
If we could figure out what change regressed this, that would help.
Comment 10 Simon Fraser (smfr) 2012-04-04 23:24:15 PDT
Caused by http://trac.webkit.org/changeset/97886
Comment 11 Adele Peterson 2012-04-05 14:46:16 PDT
Created attachment 135908 [details]
patch

Uploading for review.  Since these scrollbars aren't testable in DRT, I'm manually testing on multiple platforms before this goes in.
Comment 12 Adele Peterson 2012-04-05 22:24:11 PDT
Fixed in http://trac.webkit.org/changeset/113415
Comment 13 Mehmet 2012-04-05 22:30:16 PDT
Thanks!!!