Bug 7340 - Too many redirects occurred trying to open Yahoo! Groups page
Summary: Too many redirects occurred trying to open Yahoo! Groups page
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://groups.yahoo.com/group/MGE2005/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2006-02-18 09:11 PST by Victor Morel
Modified: 2007-08-07 10:02 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Morel 2006-02-18 09:11:41 PST
When i try to open a folder in a yahoo groups, it cannot open. 
Too many redirects occurred trying to open “http://groups.yahoo.com/group/MGE2005/auth?check=G&done=http%3A%2F%2Fgroups%2Eyahoo%2Ecom%2Fgroup%2FMGE2005%2Ffiles%2FLiderazgo%2520Gestion%2520de%2520Empresas%2FRes%2580%25A0%25A0%25FAmenes%2F”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.
Comment 1 Joost de Valk (AlthA) 2006-02-18 10:20:44 PST
The error you got suggested you didn't allow cookies. Isn't that the problem? Otherwise, could you give us some more information on how to reproduce this?
Comment 2 Victor Morel 2006-02-18 10:27:03 PST
I'm allowing cookies. I you want to join this group for test: http://groups.yahoo.com/group/MGE2005/
When you go to Files, click on the link "Gestión Talento Humano". This link have problem, and many others. With Firefox i can enter.
(In reply to comment #1)
> The error you got suggested you didn't allow cookies. Isn't that the problem?
> Otherwise, could you give us some more information on how to reproduce this?
> 

Comment 3 Joost de Valk (AlthA) 2006-02-18 10:35:39 PST
Confirmed, weird stuff.
Comment 4 Mark Fleming 2007-07-31 06:46:38 PDT
This bug is becoming a real issue... due to Signal sign-on at the University which uses redirection to authenticate then redirect back to original page.

Solution for the university is:

"We haven’t been able to solve the safari problem either.
It’s a problem safari has that other browsers don’t.

We are going to put some text up that says IE or Firefox recommended."
Comment 5 David Kilzer (:ddkilzer) 2007-07-31 07:46:39 PDT
The Yahoo! Groups issue (and likely the issue in Comment #4) is a bug where cookies are not sent properly when requesting a page.  This is a well-known (to me) bug in Tiger's (Mac OS X 10.4.x) cookie handling code.  See Bug 3512 (and its duplicates) for more examples.

If anyone has a Windows system available, the Safari 3 Public Beta for Windows should work in both of these situations.  I would appreciate it if someone could test that software to see if it fixes the issue.

Comment 6 David Kilzer (:ddkilzer) 2007-07-31 11:46:12 PDT
(In reply to comment #5)
> The Yahoo! Groups issue (and likely the issue in Comment #4) is a bug where
> cookies are not sent properly when requesting a page.  This is a well-known (to
> me) bug in Tiger's (Mac OS X 10.4.x) cookie handling code.  See Bug 3512 (and
> its duplicates) for more examples.

This issue is NOT the same as Bug 3512.
Comment 7 David Kilzer (:ddkilzer) 2007-07-31 11:48:03 PDT
<rdar://problem/5374180>
Comment 8 David Kilzer (:ddkilzer) 2007-07-31 12:00:09 PDT
* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. [ONE-TIME] Sign up for Yahoo! (Mail) account.
3. Log into Yahoo! account.
4. Go to URL:  http://groups.yahoo.com/group/MGE2005/
5. [ONE-TIME] Add yourself to the group.
6. Click on the "Files" link in the left nav bar.
7. Click on the "Gestión Estratégica" link in the content area to open the "folder".

* EXPECTED RESULTS
The page should load and display a list of files that reside in the "folder".

* ACTUAL RESULTS
Too many redirections occur because cookies are not getting sent to groups.yahoo.com properly during HTTP requests.

* REGRESSION
This occurs with Safari 3 Public Beta v. 3.0.2 as well as Safari 2.0.4 (419.3) on Mac OS X 10.4.10 (8R218).

* NOTES
Works on Firefox 2.0.0.6 on Mac OS X 10.4.10 (8R218).
Comment 9 David Kilzer (:ddkilzer) 2007-08-01 13:46:01 PDT
Closing this bug as RESOLVED/INVALID since it's not a bug in WebKit itself.  This issue will be tracked internally via the Radar bug.  Thanks!

Comment 10 David Kilzer (:ddkilzer) 2007-08-03 08:17:30 PDT
I created a test group on Yahoo! which contains a folder that demonstrates the issue:

http://tech.groups.yahoo.com/group/testing-webkit-bug-7340

Basically, if there are any "special" (accented; composition?) characters in the folder name, this behavior is seen.  If there are not any special characters, the redirect occurs with no issues.

Comment 11 David Kilzer (:ddkilzer) 2007-08-07 07:59:45 PDT
Can someone inform me what type of encoding is used to go from &eacute; (é) to %80%A0%A0%E9 in the URL?  I can't seem to find any references to this type of encoding on the Internet (or how to properly decode it), but perhaps I'm not searching for the correct terms.

Comment 12 Alexey Proskuryakov 2007-08-07 10:02:48 PDT
I don't think %80%A0%A0%E9 corresponds to any universally used encoding (0xE9 is e acute in ISO 8859-1, but the rest doesn't look familiar). I guess the URL should be treated literally, without trying to decode it.