Bug 72943 - [Qt] [WK2] [Meta] Clean up the QtWebPageProxy class
Summary: [Qt] [WK2] [Meta] Clean up the QtWebPageProxy class
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Caio Marcelo de Oliveira Filho
URL:
Keywords: Qt, QtTriaged
Depends on: 66668 72910 72928 72959 73089 73145 73150 74296 74364 74395 74407 74414 74442 74506 74525 74540
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-22 05:17 PST by Caio Marcelo de Oliveira Filho
Modified: 2011-12-15 06:31 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caio Marcelo de Oliveira Filho 2011-11-22 05:17:53 PST
QtWebPageProxy has grown out of proportions, and is currently doing too much stuff.
Comment 1 Jesus Sanchez-Palencia 2011-11-25 14:57:06 PST
*** Bug 66668 has been marked as a duplicate of this bug. ***
Comment 2 Jesus Sanchez-Palencia 2011-12-15 06:31:42 PST
Today is the day a dream became true.
R.I.P., QtWebPageProxy. You served us well. :)

http://trac.webkit.org/changeset/102932