Bug 7218 - Text underlined on mouse over
Summary: Text underlined on mouse over
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.fontanka.ru/158194
Keywords: HasReduction
: 3578 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-12 12:28 PST by Alexey Proskuryakov
Modified: 2006-02-17 15:29 PST (History)
2 users (show)

See Also:


Attachments
Reduced testcase (168 bytes, text/html)
2006-02-12 12:52 PST, mitz
no flags Details
Possible fix (1.55 KB, patch)
2006-02-13 13:27 PST, mitz
no flags Details | Formatted Diff | Diff
Added layout test and changelog (6.95 KB, patch)
2006-02-14 11:42 PST, mitz
mjs: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2006-02-12 12:28:34 PST
At this site, article text gets underlined when the mouse pointer is moved over it. This doesn't look like an intended effect, and doesn't happen in Firefox.
Comment 1 mitz 2006-02-12 12:52:50 PST
Created attachment 6437 [details]
Reduced testcase
Comment 2 Joost de Valk (AlthA) 2006-02-12 13:01:43 PST
Both Opera and Win IE don't do anything on hover either... Think we should fix this.
Comment 3 mitz 2006-02-13 13:27:18 PST
Created attachment 6466 [details]
Possible fix

Apparently *:hover and *:active never match anything in quirks mode in Firefox and IE. If the fix looks right, please r- and I will add a testcase and a ChangeLog entry.
Comment 4 Dave Hyatt 2006-02-13 13:29:51 PST
Comment on attachment 6466 [details]
Possible fix

Yup, that's absolutely right.
Comment 5 mitz 2006-02-13 13:31:55 PST
Comment on attachment 6466 [details]
Possible fix

Removing r+ so that it dosn't show in the commit queue until I add a layout test and changelog.
Comment 6 mitz 2006-02-14 11:42:21 PST
Created attachment 6485 [details]
Added layout test and changelog
Comment 7 Maciej Stachowiak 2006-02-14 22:44:13 PST
Comment on attachment 6485 [details]
Added layout test and changelog

r=me
Comment 8 mitz 2006-02-17 00:24:15 PST
*** Bug 3578 has been marked as a duplicate of this bug. ***
Comment 9 mitz 2006-02-17 15:29:32 PST
The fix for this bug caused bug 7327.