Bug 7216 - white-space: pre-wrap collapses leading whitespace following a newline
Summary: white-space: pre-wrap collapses leading whitespace following a newline
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-12 10:36 PST by mitz
Modified: 2006-02-17 01:29 PST (History)
1 user (show)

See Also:


Attachments
patch (12.44 KB, patch)
2006-02-12 10:49 PST, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-02-12 10:36:48 PST
[Reported by Dave Hyatt]

white-space: pre-wrap collapses whitespace at the start of the line if the previous line ends in a newline. The root cause is that previousLineBrokeCleanly is only being set for <br> and not for breaks caused by newlines.

Patch coming up.
Comment 1 mitz 2006-02-12 10:49:23 PST
Created attachment 6436 [details]
patch
Comment 2 Dave Hyatt 2006-02-12 17:34:44 PST
Comment on attachment 6436 [details]
patch

r=me