Bug 7207 - filters apply more and more times on each repaint
Summary: filters apply more and more times on each repaint
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 6713
  Show dependency treegraph
 
Reported: 2006-02-11 21:45 PST by Maciej Stachowiak
Modified: 2006-02-13 15:00 PST (History)
0 users

See Also:


Attachments
patch to fix issue (1.14 KB, patch)
2006-02-12 03:59 PST, Alexander Kellett
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2006-02-11 21:45:58 PST
Filters appear to apply more and more times on each repaint. This is visible in the effect of the filter, and the paint gets slower and slower each time.

Steps to reproduce:

1) Load LayoutTests/svg/custom/text-filter.svg
2) Open another (empty) tab
3) Switch back and forth between the tabs, for example using cmd-shift-[ and cmd-shift=]

Results:

The text gets more blurry each time, and the paint takes longer each time.

Expected results:

The visual output should be the same each time and should not take any longer.
Comment 1 Eric Seidel (no email) 2006-02-12 01:24:40 PST
This is likely the cause of:
http://bugzilla.opendarwin.org/show_bug.cgi?id=6713
Comment 2 Alexander Kellett 2006-02-12 03:59:04 PST
Created attachment 6429 [details]
patch to fix issue
Comment 3 Eric Seidel (no email) 2006-02-12 04:56:41 PST
Comment on attachment 6429 [details]
patch to fix issue

Looks good.  It's an old if statement, which seems to have lost it's actual content (I think it used to have a NSLog in that case).