Bug 71762 - Fix gcc 4.4 compilation warnings in DFG 32_64
Summary: Fix gcc 4.4 compilation warnings in DFG 32_64
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 71686
  Show dependency treegraph
 
Reported: 2011-11-07 21:29 PST by Yuqiang Xian
Modified: 2011-11-07 22:52 PST (History)
3 users (show)

See Also:


Attachments
the patch (2.14 KB, patch)
2011-11-07 21:33 PST, Yuqiang Xian
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuqiang Xian 2011-11-07 21:29:49 PST
gcc 4.4 on Linux will complain "comparison always false due to limited range of data type" for a function (registersMatched) in DFG, as in one file the call to this function always has the second parameter as "InvalidGPRReg".

Patch forthcoming.
Comment 1 Yuqiang Xian 2011-11-07 21:33:28 PST
Created attachment 113984 [details]
the patch
Comment 2 WebKit Review Bot 2011-11-07 22:52:00 PST
Comment on attachment 113984 [details]
the patch

Clearing flags on attachment: 113984

Committed r99525: <http://trac.webkit.org/changeset/99525>
Comment 3 WebKit Review Bot 2011-11-07 22:52:04 PST
All reviewed patches have been landed.  Closing bug.