Bug 7157 - An asterisk in a CSS property name breaks CSS handling (Many layout problems at letras.terra.com.br)
Summary: An asterisk in a CSS property name breaks CSS handling (Many layout problems ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://dalida.letras.terra.com.br/let...
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2006-02-09 10:28 PST by Alexey Proskuryakov
Modified: 2006-03-29 07:54 PST (History)
0 users

See Also:


Attachments
Test case reduction (partly) (494 bytes, text/html)
2006-02-10 09:14 PST, jonathanjohnsson
no flags Details
Test case reduction (partly), second try (451 bytes, text/html)
2006-02-10 12:06 PST, jonathanjohnsson
no flags Details
proposed fix (3.31 KB, patch)
2006-03-27 09:31 PST, Alexey Proskuryakov
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2006-02-09 10:28:42 PST
http://dalida.letras.terra.com.br/letras/60380

The page looks quite broken - not even sure if all the problems have the same root cause. Looks fine in Firefox.

Please note that the main text is actually broken (missing line breaks and badly encoded entities), so this is not part of the problem.
Comment 1 jonathanjohnsson 2006-02-10 09:14:17 PST
Created attachment 6388 [details]
Test case reduction (partly)

Part of the problem Safari has with this page is stars (*) used as prefixes to css property names. I'm not sure why they use this, but it doesn't validate. The part of the css that comes after these css properties seems to be ignored. Removing the star in the css of the attachment gives identical renderings from Firefox and Safari.

Removing all stars from the css of the real page removes most of the rendering errors in Safari. Curiously this breaks the rendering in Firefox.

Opera 9 agrees with Firefox in all cases.
Comment 2 jonathanjohnsson 2006-02-10 12:06:46 PST
Created attachment 6395 [details]
Test case reduction (partly), second try

I forgot an http refresh tag in the previous attachment. Nice during reduction, quite irritating and hitting on the server otherwise. Sorry for the spam.
Comment 3 Alexey Proskuryakov 2006-02-10 13:15:48 PST
Thank you for this really nice reduction!

Even if there are additional issues that make this page break, I think they will need separate bugs for tracking, and this bug should be devoted to the problem you found.
Comment 4 Alexey Proskuryakov 2006-03-27 09:31:56 PST
Created attachment 7337 [details]
proposed fix

Handle the case when the last rule is an error, and it doesn't end with a semicolon.
Comment 5 Darin Adler 2006-03-29 03:40:37 PST
Comment on attachment 7337 [details]
proposed fix

Looks fine, r=me.