Bug 71345 - Implement the MediaStreamEvent constructor for JSC
Summary: Implement the MediaStreamEvent constructor for JSC
Status: RESOLVED DUPLICATE of bug 107411
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
URL:
Keywords:
Depends on:
Blocks: 67824 71344
  Show dependency treegraph
 
Reported: 2011-11-01 18:12 PDT by Dominic Cooney
Modified: 2013-01-20 21:00 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Cooney 2011-11-01 18:12:02 PDT
MediaStreamEvent should have a constructor as defined in the spec here: <http://www.whatwg.org/specs/web-apps/current-work/multipage/video-conferencing-and-peer-to-peer-communication.html#mediastreamevent>
Comment 1 Harald Tveit Alvestrand 2011-11-12 15:04:55 PST
Note that the spec that other patches are trying to conform to is here:

http://dev.w3.org/2011/webrtc/editor/webrtc.html

Please ensure that if you want to implement stuff that is not in that spec, also raise the issue with the W3 group, so that we can get the spec changed if the functionality is appropriate.
Comment 2 Adam Barth 2011-11-13 22:51:06 PST
Harald and I chatted by email.  He's going to ask the WebRTC working group to update the spec to align better with DOM4.
Comment 3 Kentaro Hara 2011-11-13 23:13:44 PST
Thanks, I will wait until the spec is well defined.
Comment 4 Adam Barth 2011-11-13 23:17:01 PST
> Thanks, I will wait until the spec is well defined.

IMHO, we don't need to wait.  It's pretty clear the WebRTC spec is going to align with DOM4.
Comment 5 Kentaro Hara 2013-01-20 21:00:48 PST

*** This bug has been marked as a duplicate of bug 107411 ***