Bug 7054 - Vertical scroll bars do not appear or do not scroll completely.
Summary: Vertical scroll bars do not appear or do not scroll completely.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 417.x
Hardware: PC OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.tech-recipes.com
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2006-02-03 12:58 PST by david kirk
Modified: 2006-02-11 12:09 PST (History)
2 users (show)

See Also:


Attachments
stylesheet showing bug (11.19 KB, text/css)
2006-02-03 13:32 PST, david kirk
no flags Details
html of the bug (9.35 KB, text/plain)
2006-02-03 13:34 PST, david kirk
no flags Details
html code of the bug (24.28 KB, text/html)
2006-02-03 13:38 PST, david kirk
no flags Details
Testcase (3.12 KB, text/html)
2006-02-04 07:23 PST, mitz
no flags Details
Testcase reduction (515 bytes, text/html)
2006-02-07 11:45 PST, jonathanjohnsson
no flags Details
Implement {leftmost, rightmost, lowest}Position for RenderTableSection (12.13 KB, patch)
2006-02-10 05:06 PST, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description david kirk 2006-02-03 12:58:57 PST
When reformatting tech-recipes, we noted this possible bug.  Any user of a webkit browser either sees no scroll part or a scroll bar that does not span the length of the page.  The CSS is validated and the HTML is valid except for some minor (unencoded ampersands in URLs) errors.  The page renders correctly in opera, IE5-7, and firefox.

Feel free to contact me for further information.
Comment 1 david kirk 2006-02-03 13:32:44 PST
Created attachment 6225 [details]
stylesheet showing bug
Comment 2 david kirk 2006-02-03 13:34:13 PST
Created attachment 6226 [details]
html of the bug
Comment 3 david kirk 2006-02-03 13:38:27 PST
Created attachment 6227 [details]
html code of the bug
Comment 4 david kirk 2006-02-04 06:27:39 PST
In order to attempt to help, I have created a barebones html structure documenting this bug:

http://www.bronch.com/downloads/webkit_bug/index.html
Comment 5 mitz 2006-02-04 07:23:27 PST
Created attachment 6245 [details]
Testcase

Attaching David Kirk's reduction from http://www.bronch.com/downloads/webkit_bug/index.html

This can probably be further reduced, so I'm leaving the NeedsReduction keyword for now.
Comment 6 jonathanjohnsson 2006-02-07 11:45:12 PST
Created attachment 6333 [details]
Testcase reduction

(In reply to comment #5)
> Created an attachment (id=6245) [edit]
> Testcase
> 
> Attaching David Kirk's reduction from
> http://www.bronch.com/downloads/webkit_bug/index.html
> 
> This can probably be further reduced, so I'm leaving the NeedsReduction keyword
> for now.
> 

I tried to reduce it as much as possible, without removing the scrollbar issue. (Used the above testcase as base, hope that's ok.)
The page looks the same in HTML 4.01 Strict. Removing any of the divs or the table, or hanging any of the divs' position values, makes the vertical scrollbar appear.

My first try at this sort of thing. Couldn't connect to #webkit, to get to know how to do this the best/right way.
Comment 7 mitz 2006-02-09 12:09:00 PST
Great reduction!
Comment 8 mitz 2006-02-10 05:06:38 PST
Created attachment 6384 [details]
Implement {leftmost, rightmost, lowest}Position for RenderTableSection

The patch affects an existing test, fast/replaced/width100percent.html, and includes updated results. That test shows a repaint problem when scrolling, but that's not caused by the patch (if you make the window narrow enough and scroll it horizontally w/o the patch it also fails to repaint completely in TOT).
Comment 9 Darin Adler 2006-02-10 08:46:14 PST
Comment on attachment 6384 [details]
Implement {leftmost, rightmost, lowest}Position for RenderTableSection

Looks great to me, but this is the kind of patch Hyatt should review.
Comment 10 Dave Hyatt 2006-02-11 01:07:39 PST
Comment on attachment 6384 [details]
Implement {leftmost, rightmost, lowest}Position for RenderTableSection

r=me