Bug 6578 - Benchjs broken
Summary: Benchjs broken
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.24fun.com/downloadcenter/b...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-16 00:51 PST by Henk
Modified: 2007-02-23 02:57 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henk 2006-01-16 00:51:43 PST
The second test2 (open popups) never completes.

Javascript Console shows the following error:

--
TypeError: Undefined value
http://www.24fun.com/downloadcenter/benchjs/testpopup.html

Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL http://www.
24fun.com/downloadcenter/benchjs/testpopup.html. Domains must match.
--

The test also fails with version 2.0.3.
Comment 1 Alexey Proskuryakov 2006-01-16 03:23:25 PST
Duplicate of bug 5292?
Comment 2 Maciej Stachowiak 2007-02-23 02:39:13 PST
You have to disable popup blocking for Test 2 to work.  Same is true in other browsers.The benchmark even says to disable popup blocking.
Comment 3 Henk 2007-02-23 02:57:22 PST
(In reply to comment #2)
> You have to disable popup blocking for Test 2 to work.  Same is true in other
> browsers.The benchmark even says to disable popup blocking.
> 

I know, but earlier versions of webkit/Safari failed nontheless.