Bug 65433 - REGRESSION (r91777): fast/css/font-family-pictograph.html failing on SnowLeopard Intel Release (Tests)
Summary: REGRESSION (r91777): fast/css/font-family-pictograph.html failing on SnowLeop...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://build.webkit.org/results/SnowL...
Keywords: LayoutTestFailure, MakingBotsRed, Regression
Depends on:
Blocks:
 
Reported: 2011-07-31 12:57 PDT by Ryosuke Niwa
Modified: 2011-07-31 17:16 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 mitz 2011-07-31 13:30:03 PDT
(In reply to comment #0)
> fast/css/font-family-pictograph.html started failing on SnowLeopard Intel Release (Tests) between r91771 and r91799 (inclusive).
> 
> http://trac.webkit.org/log/trunk?rev=91799&stop_rev=91771

The test was introduced in r91777, so it did not “start failing”. It just needs expected results for Snow Leopard and earlier.

> 
> http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r91770%20(31747)/results.html passed

These are results for r91770, when the test did not exist. It did not pass.
Comment 2 mitz 2011-07-31 13:33:19 PDT
Expected results added in <http://trac.webkit.org/r92086>.
Comment 3 Ryosuke Niwa 2011-07-31 17:15:58 PDT
(In reply to comment #1)
> (In reply to comment #0)
> > fast/css/font-family-pictograph.html started failing on SnowLeopard Intel Release (Tests) between r91771 and r91799 (inclusive).
> > 
> > http://trac.webkit.org/log/trunk?rev=91799&stop_rev=91771
> 
> The test was introduced in r91777, so it did not “start failing”. It just needs expected results for Snow Leopard and earlier.

Right.  I used TestFailures tool to auto-generate this bug.  Maybe TestFailures can be smart and detect newly added tests?  Thanks for the quick fix anyway.

And I'll really appreciate if you could take a look at https://bugs.webkit.org/show_bug.cgi?id=65439 as well.
Comment 4 Ryosuke Niwa 2011-07-31 17:16:58 PDT
(In reply to comment #3)
> 
> Right.  I used TestFailures tool to auto-generate this bug.  Maybe TestFailures can be smart and detect newly added tests?  Thanks for the quick fix anyway.

Already filed https://bugs.webkit.org/show_bug.cgi?id=61645