Bug 62720 - REGRESSION (r88719): 5by5.tv schedule is not visible
Summary: REGRESSION (r88719): 5by5.tv schedule is not visible
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Normal
Assignee: Oliver Hunt
URL: http://5by5.tv/schedule
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2011-06-15 04:47 PDT by Vincent
Modified: 2011-06-15 14:47 PDT (History)
2 users (show)

See Also:


Attachments
screen picture of browser window, showing invisible/unloaded schedule (545.70 KB, image/png)
2011-06-15 04:47 PDT, Vincent
no flags Details
Patch (4.24 KB, patch)
2011-06-15 14:04 PDT, Oliver Hunt
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent 2011-06-15 04:47:06 PDT
Created attachment 97276 [details]
screen picture of browser window, showing invisible/unloaded schedule

Safari 5.0.5 (6533.21.1, r88851)

Schedule not visible
Comment 1 Alexey Proskuryakov 2011-06-15 13:04:31 PDT
Bisection says that it broke in r88719.
Comment 2 Oliver Hunt 2011-06-15 13:05:54 PDT
This is sad making.
Comment 3 Oliver Hunt 2011-06-15 13:20:12 PDT
I see the problem
Comment 4 Oliver Hunt 2011-06-15 14:04:05 PDT
Created attachment 97362 [details]
Patch
Comment 5 Darin Adler 2011-06-15 14:12:46 PDT
Comment on attachment 97362 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=97362&action=review

> Source/JavaScriptCore/parser/Lexer.h:205
> +            if ((!WTF::isASCII(*ptr)) || (*ptr == '\\') || (*ptr == '_') || (*ptr == '$'))

THat really looks like too many parentheses to me. Are there any other characters that might be an issue.
Comment 6 Oliver Hunt 2011-06-15 14:47:26 PDT
Committed r88974: <http://trac.webkit.org/changeset/88974>