Bug 62683 - [Chromium][Qt] Some slider clicking tests fail
Summary: [Chromium][Qt] Some slider clicking tests fail
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kent Tamura
URL:
Keywords:
Depends on: 52920
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-14 17:48 PDT by Kent Tamura
Modified: 2011-07-11 13:36 PDT (History)
3 users (show)

See Also:


Attachments
Patch (7.85 KB, patch)
2011-06-14 23:05 PDT, Kent Tamura
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-01 (1.32 MB, application/zip)
2011-06-14 23:20 PDT, WebKit Review Bot
no flags Details
Patch 2 (8.56 KB, patch)
2011-06-14 23:45 PDT, Kent Tamura
dglazkov: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Tamura 2011-06-14 17:48:59 PDT
By r88757, the following three tests fail on Chromium-win and Chromium-linux:
fast/forms/slider-delete-while-dragging-thumb.html
fast/forms/slider-mouse-events.html
fast/forms/slider-onchange-event.html

The following test fails on Qt-Linux:
fast/forms/slider-onchange-event.html

Probably because of slider thumb size differences.
Comment 1 Kent Tamura 2011-06-14 22:55:37 PDT
The trigger of the failures is r88757, but the root cause is not r88757.
Comment 2 Kent Tamura 2011-06-14 23:05:29 PDT
Created attachment 97235 [details]
Patch
Comment 3 WebKit Review Bot 2011-06-14 23:19:59 PDT
Comment on attachment 97235 [details]
Patch

Attachment 97235 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/8841557

New failing tests:
fast/forms/slider-mouse-events.html
Comment 4 WebKit Review Bot 2011-06-14 23:20:04 PDT
Created attachment 97236 [details]
Archive of layout-test-results from ec2-cr-linux-01

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-01  Port: Chromium  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 5 Kent Tamura 2011-06-14 23:45:49 PDT
Created attachment 97239 [details]
Patch 2

Remove a Chromium-specific result
Comment 6 Kent Tamura 2011-06-15 21:39:07 PDT
Thank you for reviewing.

Landed: http://trac.webkit.org/changeset/89004
Comment 7 Mark Rowe (bdash) 2011-07-11 13:36:43 PDT
This broke scrubbing in the timeline of media elements.  See bug 64314 for details.