Currently we use the names XSSFilter and XSSAuditor throughout the project. I propose choosing one name for consistency. In particular, I propose renaming XSSFilter to XSSAuditor since the XSS Auditor has been referenced in various publications, including on the Apple Safari features page <http://www.apple.com/safari/features.html#security> and <http://support.apple.com/kb/DL1046>. That being said, I am open to rename all XSSAuditor references to the XSSFilter or to some other name for consistency.
Created attachment 95323 [details]
Rename XSSFilter to XSSAuditor
Note, this patch also renames the directory PerformanceTests/XSSFilter toXSSAuditor, but this diff only reflects the deleted files. For some reason svn diff only outputs a diff for the deleted files (e.g. WebKit/PerformanceTests/XSSFilter/large-post-many-events.html) instead of both a delete file diff and an add file diff. Although, svn stat does reflect the directory rename.
Committed r87708: <http://trac.webkit.org/changeset/87708>