Bug 6149 - REGRESSION (WebCore-417.5): horizontal scrollbar in overflow with top border doesn't receive mouse events
: REGRESSION (WebCore-417.5): horizontal scrollbar in overflow with top border ...
Status: VERIFIED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 420+
: Macintosh Mac OS X 10.4
: P1 Normal
Assigned To: Beth Dakin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 09:53 PST by mitz@webkit.org
Modified: 2006-01-31 21:20 PST (History)
0 users

See Also:


Attachments
Testcase (913 bytes, text/html)
2005-12-19 09:58 PST, mitz@webkit.org
no flags Details
Remove borderTop() from horizontal scrollbar rect computation (3.11 KB, patch)
2005-12-19 10:15 PST, mitz@webkit.org
bdakin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz@webkit.org 2005-12-19 09:53:45 PST
Summary: hit-testing for the horizontal scroll bar of an overflow is off by by the width of the top border.

To reproduce: open the testcase. The horizontal scrollbar doesn't respond to clicking and dragging. 
Clicking inside the blue rect just below the scrollbar gives this error in the console (if running a debug 
build): ERROR: KHTML says we hit a RenderWidget, but AppKit doesn't agree we hit 
the corresponding NSView.

I have a patch, but like with bug 5829, I don't know how to make an automated test.
Comment 1 mitz@webkit.org 2005-12-19 09:58:09 PST
Created attachment 5152 [details]
Testcase
Comment 2 mitz@webkit.org 2005-12-19 10:15:01 PST
Created attachment 5153 [details]
Remove borderTop() from horizontal scrollbar rect computation
Comment 3 Joost de Valk (AlthA) 2006-01-22 04:52:56 PST
Removing keyword(s) cause bug is closed.
Comment 4 Joost de Valk (AlthA) 2006-01-22 04:56:02 PST
Removing keyword(s) since bug is fixed.
Comment 5 Joost de Valk (AlthA) 2006-01-22 05:00:17 PST
Removing keyword(s) since bug is fixed.
Comment 6 Eric Seidel 2006-01-31 21:20:51 PST
Removing Regression keyword from bugs already fixed.