Bug 61471 - Web Inspector: REGRESSION - Certain characters in console cause browser process to crash
Summary: Web Inspector: REGRESSION - Certain characters in console cause browser proce...
Status: RESOLVED DUPLICATE of bug 61194
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Critical
Assignee: Nobody
URL: http://timmywillison.com
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-25 14:45 PDT by timmywil
Modified: 2011-05-26 09:00 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description timmywil 2011-05-25 14:45:28 PDT
I can consistently cause a crash on any site by inputting two characters into the web inspector console: }.

I ran into this when playing with a plain object.
Comment 1 Yury Semikhatsky 2011-05-26 05:08:53 PDT
Which characters cause this crash? I cannot reproduce it on WebKit r87373 Safari Mac.
Comment 2 timmywil 2011-05-26 08:17:55 PDT
Strange.  I've updated again this morning and I can no longer reproduce.  Btw, this was consistently reproducible for me on yesterday's version of Chromium.
Comment 3 Yury Semikhatsky 2011-05-26 09:00:21 PDT
Ok, if it was Chromium then it's a known issue(https://bugs.webkit.org/show_bug.cgi?id=61194) which was fixed in r87278.

*** This bug has been marked as a duplicate of bug 61194 ***