Bug 60849 - HTTP video-on-demand streams frequently have live stream UI
Summary: HTTP video-on-demand streams frequently have live stream UI
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Unspecified
: P2 Normal
Assignee: Eric Carlson
URL:
Keywords: InRadar, PlatformOnly
Depends on:
Blocks:
 
Reported: 2011-05-14 18:42 PDT by Eric Carlson
Modified: 2011-05-14 22:40 PDT (History)
0 users

See Also:


Attachments
Proposed patch. (12.85 KB, patch)
2011-05-14 22:20 PDT, Eric Carlson
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Carlson 2011-05-14 18:42:57 PDT
VOD streams are frequently identified as Live streams, so they get the media controls for a live stream. This is a serious regression because the live stream controls do not have a timeline scrubber, so it is impossible to seek.

<rdar://problem/9440502>
Comment 1 Eric Carlson 2011-05-14 22:20:00 PDT
Created attachment 93574 [details]
Proposed patch.
Comment 2 Eric Carlson 2011-05-14 22:40:45 PDT
trac.webkit.org/changeset/86501