Bug 6043 - Incorrect selection highlighting in pre-formatted text with tabs
: Incorrect selection highlighting in pre-formatted text with tabs
Status: VERIFIED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
http://perldoc.perl.org/perl.html
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 08:53 PST by mitz@webkit.org
Modified: 2005-12-26 14:08 PST (History)
0 users

See Also:


Attachments
reduced testcase (225 bytes, text/html)
2005-12-11 10:25 PST, mitz@webkit.org
no flags Details
Correct parameters in calls to RenderText::width() (6.19 KB, patch)
2005-12-11 14:03 PST, mitz@webkit.org
no flags Details | Formatted Diff | Diff
Correct parameters in calls to RenderText::width() (7.87 KB, patch)
2005-12-11 23:27 PST, mitz@webkit.org
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz@webkit.org 2005-12-11 08:53:38 PST
Summary: the selection highlight is painted incorrectly (offset to the right) when you select text on the 
right hand side of the man pages lists, e.g. try to select "references" in "Perl references short introduction". 
It does not happen on the two lines that don't start with a link (perl and perltoc).
Comment 1 mitz@webkit.org 2005-12-11 10:25:32 PST
Created attachment 5041 [details]
reduced testcase
Comment 2 mitz@webkit.org 2005-12-11 14:03:00 PST
Created attachment 5043 [details]
Correct parameters in calls to RenderText::width()

The fix for rdar://problem/3792529 is porbably responsible for at least one
first-line regression that this patch fixes.
Comment 3 mitz@webkit.org 2005-12-11 14:07:27 PST
Comment on attachment 5043 [details]
Correct parameters in calls to RenderText::width()

Looks like there's more to it than this.
Comment 4 mitz@webkit.org 2005-12-11 23:27:43 PST
Created attachment 5048 [details]
Correct parameters in calls to RenderText::width()
Comment 5 Darin Adler 2005-12-12 08:56:53 PST
Comment on attachment 5048 [details]
Correct parameters in calls to RenderText::width()

r=me

Annoying that the compiler didn't catch this one. Shows that default values for
parameters can cause problems.