Bug 60056 - [Chromium] Crash Report - Stack Signature: WebCore::Canvas2DLayerChromium::setLayerRenderer
Summary: [Chromium] Crash Report - Stack Signature: WebCore::Canvas2DLayerChromium::se...
Status: RESOLVED DUPLICATE of bug 59965
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-03 13:04 PDT by Justin Novosad
Modified: 2022-02-27 23:36 PST (History)
4 users (show)

See Also:


Attachments
Patch (1.50 KB, patch)
2011-05-03 13:09 PDT, Justin Novosad
junov: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Novosad 2011-05-03 13:04:24 PDT
This is in reference to chromium bug:
http://code.google.com/p/chromium/issues/detail?id=80736


Thread 0 *CRASHED* ( EXCEPTION_ACCESS_VIOLATION_READ @ 0x00000004 )

0x6bf625a6	 [chrome.dll	 - canvas2dlayerchromium.cpp:123]	WebCore::Canvas2DLayerChromium::setLayerRenderer(WebCore::LayerRendererChromium *)
0x6bf68131	 [chrome.dll	 - layerrendererchromium.cpp:534]	WebCore::LayerRendererChromium::updatePropertiesAndRenderSurfaces(WebCore::LayerChromium *,WebCore::TransformationMatrix const &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf6880d	 [chrome.dll	 - layerrendererchromium.cpp:735]	WebCore::LayerRendererChromium::updatePropertiesAndRenderSurfaces(WebCore::LayerChromium *,WebCore::TransformationMatrix const &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf6880d	 [chrome.dll	 - layerrendererchromium.cpp:735]	WebCore::LayerRendererChromium::updatePropertiesAndRenderSurfaces(WebCore::LayerChromium *,WebCore::TransformationMatrix const &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf6880d	 [chrome.dll	 - layerrendererchromium.cpp:735]	WebCore::LayerRendererChromium::updatePropertiesAndRenderSurfaces(WebCore::LayerChromium *,WebCore::TransformationMatrix const &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf6880d	 [chrome.dll	 - layerrendererchromium.cpp:735]	WebCore::LayerRendererChromium::updatePropertiesAndRenderSurfaces(WebCore::LayerChromium *,WebCore::TransformationMatrix const &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf6880d	 [chrome.dll	 - layerrendererchromium.cpp:735]	WebCore::LayerRendererChromium::updatePropertiesAndRenderSurfaces(WebCore::LayerChromium *,WebCore::TransformationMatrix const &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf6880d	 [chrome.dll	 - layerrendererchromium.cpp:735]	WebCore::LayerRendererChromium::updatePropertiesAndRenderSurfaces(WebCore::LayerChromium *,WebCore::TransformationMatrix const &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &,WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf67a7b	 [chrome.dll	 - layerrendererchromium.cpp:284]	WebCore::LayerRendererChromium::updateLayers(WTF::Vector<WTF::RefPtr<WebCore::CCLayerImpl>,0> &)
0x6bf67846	 [chrome.dll	 - layerrendererchromium.cpp:208]	WebCore::LayerRendererChromium::updateAndDrawLayers()
0x6c0c1004	 [chrome.dll	 - webviewimpl.cpp:1109]	WebKit::WebViewImpl::composite(bool)
0x6bd6f248	 [chrome.dll	 - render_widget.cc:643]	RenderWidget::DoDeferredUpdate()
0x6bd6ef01	 [chrome.dll	 - render_widget.cc:547]	RenderWidget::CallDoDeferredUpdate()
0x6bd70d56	 [chrome.dll	 - task.h:332]	RunnableMethod<RenderWidget,void ( RenderWidget::*)(void),Tuple0>::Run()



Product: Chrome
Stack Signature: WebCore::Canvas2DLayerChromium::setLayerRenderer(WebCore::LayerRendererChromium *)-AC3EFE
New Signature Label: WebCore::Canvas2DLayerChromium::setLayerRenderer(WebCore::LayerRendererChromium *)
New Signature Hash: 7ba80089_e0b351af_12287d77_5042fc63_b73cfaaa

Report link: http://go/crash/reportdetail?reportid=de852b069c6855ea

Meta information:
Product Name: Chrome
Product Version: 13.0.749.0
Report ID: de852b069c6855ea
Report Time: 2011/04/27 18:26:13, Wed
Uptime: 8 sec
Cumulative Uptime: 0 sec
OS Name: Windows NT
OS Version: 6.1.7601 Service Pack 1
CPU Architecture: x86
CPU Info: AuthenticAMD family 16 model 4 stepping 3
Comment 1 Justin Novosad 2011-05-03 13:09:52 PDT
Created attachment 92113 [details]
Patch
Comment 2 Justin Novosad 2011-05-03 13:16:15 PDT
Comment on attachment 92113 [details]
Patch

Cancelling.  Fix is redundant with https://bug-59965-attachments.webkit.org/attachment.cgi?id=91991
Comment 3 Justin Novosad 2011-05-03 13:20:35 PDT

*** This bug has been marked as a duplicate of bug 59965 ***