Bug 59977 - new-run-webkit-tests: fix http server startup/shutdown
Summary: new-run-webkit-tests: fix http server startup/shutdown
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Dirk Pranke
URL:
Keywords:
: 50596 (view as bug list)
Depends on:
Blocks: 59985 59993
  Show dependency treegraph
 
Reported: 2011-05-02 16:29 PDT by Dirk Pranke
Modified: 2011-06-06 15:32 PDT (History)
5 users (show)

See Also:


Attachments
Patch (17.34 KB, patch)
2011-05-02 16:53 PDT, Dirk Pranke
no flags Details | Formatted Diff | Diff
Patch (17.33 KB, patch)
2011-05-02 16:55 PDT, Dirk Pranke
ojan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Pranke 2011-05-02 16:29:58 PDT
new-run-webkit-tests: fix http server startup/shutdown
Comment 1 Dirk Pranke 2011-05-02 16:53:50 PDT
Created attachment 92004 [details]
Patch
Comment 2 Dirk Pranke 2011-05-02 16:55:44 PDT
Created attachment 92005 [details]
Patch
Comment 3 Dirk Pranke 2011-05-02 18:12:51 PDT
*** Bug 50596 has been marked as a duplicate of this bug. ***
Comment 4 Ojan Vafai 2011-05-02 18:40:49 PDT
Comment on attachment 92005 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=92005&action=review

> Tools/Scripts/webkitpy/layout_tests/port/http_server_base.py:72
> +            _log.debug("Server isn't running at all")

Maybe something like "Server process could not be started."?
Comment 5 Tony Chang 2011-05-03 09:50:37 PDT
This patch is fine, but it's on the large side.  Seems like the three fixes you mention in the ChangeLog could have been three separate patches (or maybe two patches since fix 1 & 2 are relatively small).
Comment 6 Dirk Pranke 2011-05-03 14:18:51 PDT
Committed r85659: <http://trac.webkit.org/changeset/85659>
Comment 7 Dirk Pranke 2011-05-03 14:51:42 PDT
Reverted r85659 for reason:

restarting isn't working correctly

Committed r85665: <http://trac.webkit.org/changeset/85665>
Comment 8 Dirk Pranke 2011-06-06 15:32:26 PDT
I'm going to split this up into smaller changes and re-land them individually to simplify things. Closing.