Bug 59871 - [GTK][Stable] SIGSEGV opening Wikipedia page
Summary: [GTK][Stable] SIGSEGV opening Wikipedia page
Status: RESOLVED DUPLICATE of bug 48723
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-01 00:10 PDT by Xan Lopez
Modified: 2011-05-01 00:31 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xan Lopez 2011-05-01 00:10:23 PDT
Does not seem GTK related, but I guess we can start here. This is 1.4.0.

#0  0x00007fb81df981b1 in fontDataAt (font=<optimized out>, this=0x7fb773ca9070, realizedFontIndex=<optimized out>)
    at Source/WebCore/platform/graphics/FontFallbackList.cpp:107
107	        m_fontList.append(pair<const FontData*, bool>(result, result->isCustomFont()));

#0  0x00007fb81df981b1 in fontDataAt (font=<optimized out>, this=0x7fb773ca9070, realizedFontIndex=<optimized out>)
    at Source/WebCore/platform/graphics/FontFallbackList.cpp:107
#1  WebCore::FontFallbackList::fontDataAt (this=<optimized out>, font=<optimized out>, realizedFontIndex=<optimized out>)
    at Source/WebCore/platform/graphics/FontFallbackList.cpp:89
#2  0x00007fb81df98318 in primaryFontData (f=<optimized out>, this=0x7fb773ca9070)
    at Source/WebCore/platform/graphics/FontFallbackList.h:66
#3  WebCore::FontFallbackList::determinePitch (this=0x7fb773ca9070, font=<optimized out>)
    at Source/WebCore/platform/graphics/FontFallbackList.cpp:76
#4  0x00007fb81e0f7f40 in isFixedPitch (f=0x7fb772525978, this=0x7fb773ca9070) at Source/WebCore/platform/graphics/FontFallbackList.h:47
#5  isFixedPitch (this=0x7fb772525978) at Source/WebCore/platform/graphics/Font.h:267
#6  widthFromCache (glyphOverflow=0x7fff7ef24540, fallbackFonts=0x7fff7ef24520, xPos=0, len=9, start=0, f=..., this=0x7fb7b7a0fba8)
    at Source/WebCore/rendering/RenderText.cpp:575
#7  WebCore::RenderText::computePreferredLogicalWidths (this=0x7fb7b7a0fba8, leadWidth=0, fallbackFonts=..., glyphOverflow=...)
    at Source/WebCore/rendering/RenderText.cpp:829
#8  0x00007fb81e0f8c0d in WebCore::RenderText::computePreferredLogicalWidths (this=0x7fb7b7a0fba8, leadWidth=<optimized out>)
    at Source/WebCore/rendering/RenderText.cpp:722
#9  0x00007fb81e0f688b in WebCore::RenderText::trimmedPrefWidths (this=0x7fb7b7a0fba8, leadWidth=<optimized out>, beginMinW=
    @0x7fff7ef247a8, beginWS=<optimized out>, endMinW=@0x7fff7ef247ac, endWS=<optimized out>, hasBreakableChar=<optimized out>, hasBreak=
    @0x7fff7ef247bd, beginMaxW=@0x7fff7ef247b0, endMaxW=@0x7fff7ef247b4, minW=@0x7fff7ef247a0, maxW=@0x7fff7ef247a4, stripFrontSpaces=
    @0x7fff7ef247bc) at Source/WebCore/rendering/RenderText.cpp:620
#10 0x00007fb81e043e51 in WebCore::RenderBlock::computeInlinePreferredLogicalWidths (this=0x7fb7b7a0fa08)
    at Source/WebCore/rendering/RenderBlock.cpp:4860
#11 0x00007fb81e045088 in WebCore::RenderBlock::computePreferredLogicalWidths (this=0x7fb7b7a0fa08)
    at Source/WebCore/rendering/RenderBlock.cpp:4530
#12 0x00007fb81e0d9bd7 in WebCore::RenderTableCell::computePreferredLogicalWidths (this=0x7fb7b7a0fa08)
    at Source/WebCore/rendering/RenderTableCell.cpp:131
#13 0x00007fb81e0215cc in WebCore::AutoTableLayout::recalcColumn (this=0x7fb7235dfd80, effCol=0)
    at Source/WebCore/rendering/AutoTableLayout.cpp:75
#14 0x00007fb81e021ca2 in WebCore::AutoTableLayout::fullRecalc (this=0x7fb7235dfd80) at Source/WebCore/rendering/AutoTableLayout.cpp:185
#15 0x00007fb81e0229a2 in WebCore::AutoTableLayout::computePreferredLogicalWidths (this=0x7fb7235dfd80, minWidth=@0x7fb7b7a0f500, 
    maxWidth=@0x7fb7b7a0f504) at Source/WebCore/rendering/AutoTableLayout.cpp:224
#16 0x00007fb81e0e1edf in WebCore::RenderTable::computePreferredLogicalWidths (this=0x7fb7b7a0f4a0)
    at Source/WebCore/rendering/RenderTable.cpp:586
#17 0x00007fb81e068883 in WebCore::RenderBox::minPreferredLogicalWidth (this=0x7fb7b7a0f4a0) at Source/WebCore/rendering/RenderBox.cpp:659
#18 0x00007fb81e0de9d6 in WebCore::RenderTable::computeLogicalWidth (this=0x7fb7b7a0f4a0) at Source/WebCore/rendering/RenderTable.cpp:219
#19 0x00007fb81e0e10c6 in layout (this=0x7fb7b7a0f4a0) at Source/WebCore/rendering/RenderTable.cpp:278
#20 WebCore::RenderTable::layout (this=0x7fb7b7a0f4a0) at Source/WebCore/rendering/RenderTable.cpp:260
---Type <return> to continue, or q <return> to quit---
#21 0x00007fb81e05291c in layoutIfNeeded (this=0x7fb7b7a0f4a0) at Source/WebCore/rendering/RenderObject.h:521
#22 layoutIfNeeded (this=0x7fb7b7a0f4a0) at Source/WebCore/rendering/RenderBlock.cpp:3073
#23 WebCore::RenderBlock::insertFloatingObject (this=0x7fb7b7c30140, o=0x7fb7b7a0f4a0) at Source/WebCore/rendering/RenderBlock.cpp:3100
#24 0x00007fb81e052a11 in WebCore::RenderBlock::handleFloatingChild (this=0x7fb7b7c30140, child=<optimized out>, marginInfo=...)
    at Source/WebCore/rendering/RenderBlock.cpp:1498
#25 0x00007fb81e052a7e in WebCore::RenderBlock::handleSpecialChild (this=0x7fb7b7c30140, child=0x7fb7b7a0f4a0, marginInfo=...)
    at Source/WebCore/rendering/RenderBlock.cpp:1480
#26 0x00007fb81e053920 in WebCore::RenderBlock::layoutBlockChildren (this=0x7fb7b7c30140, relayoutChildren=true, maxFloatLogicalBottom=
    @0x7fff7ef24dac) at Source/WebCore/rendering/RenderBlock.cpp:1901
#27 0x00007fb81e0579fa in layoutBlock (pageLogicalHeight=0, relayoutChildren=true, this=0x7fb7b7c30140)
    at Source/WebCore/rendering/RenderBlock.cpp:1227
#28 WebCore::RenderBlock::layoutBlock (this=0x7fb7b7c30140, relayoutChildren=<optimized out>, pageLogicalHeight=<optimized out>)
    at Source/WebCore/rendering/RenderBlock.cpp:1131
#29 0x00007fb81e03ea6d in WebCore::RenderBlock::layout (this=0x7fb7b7c30140) at Source/WebCore/rendering/RenderBlock.cpp:1123
#30 0x00007fb81e053461 in WebCore::RenderBlock::layoutBlockChild (this=0x7fb7b7c2f8b8, child=0x7fb7b7c30140, marginInfo=..., 
    previousFloatLogicalBottom=@0x7fff7ef24ebc, maxFloatLogicalBottom=@0x7fff7ef24fdc) at Source/WebCore/rendering/RenderBlock.cpp:1967
#31 0x00007fb81e0539e8 in WebCore::RenderBlock::layoutBlockChildren (this=0x7fb7b7c2f8b8, relayoutChildren=true, maxFloatLogicalBottom=
    @0x7fff7ef24fdc) at Source/WebCore/rendering/RenderBlock.cpp:1905
#32 0x00007fb81e0579fa in layoutBlock (pageLogicalHeight=0, relayoutChildren=true, this=0x7fb7b7c2f8b8)
    at Source/WebCore/rendering/RenderBlock.cpp:1227
#33 WebCore::RenderBlock::layoutBlock (this=0x7fb7b7c2f8b8, relayoutChildren=<optimized out>, pageLogicalHeight=<optimized out>)
    at Source/WebCore/rendering/RenderBlock.cpp:1131
#34 0x00007fb81e03ea6d in WebCore::RenderBlock::layout (this=0x7fb7b7c2f8b8) at Source/WebCore/rendering/RenderBlock.cpp:1123
#35 0x00007fb81e053461 in WebCore::RenderBlock::layoutBlockChild (this=0x7fb7b7c2f690, child=0x7fb7b7c2f8b8, marginInfo=..., 
    previousFloatLogicalBottom=@0x7fff7ef250ec, maxFloatLogicalBottom=@0x7fff7ef2520c) at Source/WebCore/rendering/RenderBlock.cpp:1967
#36 0x00007fb81e0539e8 in WebCore::RenderBlock::layoutBlockChildren (this=0x7fb7b7c2f690, relayoutChildren=true, maxFloatLogicalBottom=
    @0x7fff7ef2520c) at Source/WebCore/rendering/RenderBlock.cpp:1905
#37 0x00007fb81e0579fa in layoutBlock (pageLogicalHeight=0, relayoutChildren=true, this=0x7fb7b7c2f690)
    at Source/WebCore/rendering/RenderBlock.cpp:1227
#38 WebCore::RenderBlock::layoutBlock (this=0x7fb7b7c2f690, relayoutChildren=<optimized out>, pageLogicalHeight=<optimized out>)
    at Source/WebCore/rendering/RenderBlock.cpp:1131
#39 0x00007fb81e03ea6d in WebCore::RenderBlock::layout (this=0x7fb7b7c2f690) at Source/WebCore/rendering/RenderBlock.cpp:1123
#40 0x00007fb81e053461 in WebCore::RenderBlock::layoutBlockChild (this=0x7fb7b7c2f478, child=0x7fb7b7c2f690, marginInfo=..., 
    previousFloatLogicalBottom=@0x7fff7ef2531c, maxFloatLogicalBottom=@0x7fff7ef2543c) at Source/WebCore/rendering/RenderBlock.cpp:1967
#41 0x00007fb81e0539e8 in WebCore::RenderBlock::layoutBlockChildren (this=0x7fb7b7c2f478, relayoutChildren=false, maxFloatLogicalBottom=
    @0x7fff7ef2543c) at Source/WebCore/rendering/RenderBlock.cpp:1905
#42 0x00007fb81e0579fa in layoutBlock (pageLogicalHeight=0, relayoutChildren=false, this=0x7fb7b7c2f478)
---Type <return> to continue, or q <return> to quit---
    at Source/WebCore/rendering/RenderBlock.cpp:1227
#43 WebCore::RenderBlock::layoutBlock (this=0x7fb7b7c2f478, relayoutChildren=<optimized out>, pageLogicalHeight=<optimized out>)
    at Source/WebCore/rendering/RenderBlock.cpp:1131
#44 0x00007fb81e03ea6d in WebCore::RenderBlock::layout (this=0x7fb7b7c2f478) at Source/WebCore/rendering/RenderBlock.cpp:1123
#45 0x00007fb81e053461 in WebCore::RenderBlock::layoutBlockChild (this=0x7fb7b7c2f220, child=0x7fb7b7c2f478, marginInfo=..., 
    previousFloatLogicalBottom=@0x7fff7ef2554c, maxFloatLogicalBottom=@0x7fff7ef2566c) at Source/WebCore/rendering/RenderBlock.cpp:1967
#46 0x00007fb81e0539e8 in WebCore::RenderBlock::layoutBlockChildren (this=0x7fb7b7c2f220, relayoutChildren=false, maxFloatLogicalBottom=
    @0x7fff7ef2566c) at Source/WebCore/rendering/RenderBlock.cpp:1905
#47 0x00007fb81e0579fa in layoutBlock (pageLogicalHeight=0, relayoutChildren=false, this=0x7fb7b7c2f220)
    at Source/WebCore/rendering/RenderBlock.cpp:1227
#48 WebCore::RenderBlock::layoutBlock (this=0x7fb7b7c2f220, relayoutChildren=<optimized out>, pageLogicalHeight=<optimized out>)
    at Source/WebCore/rendering/RenderBlock.cpp:1131
#49 0x00007fb81e03ea6d in WebCore::RenderBlock::layout (this=0x7fb7b7c2f220) at Source/WebCore/rendering/RenderBlock.cpp:1123
#50 0x00007fb81e1039d8 in WebCore::RenderView::layout (this=0x7fb7b7c2f220) at Source/WebCore/rendering/RenderView.cpp:130
#51 0x00007fb81df51a7b in WebCore::FrameView::layout (this=0x7fb7b5208dc0, allowSubtree=<optimized out>)
    at Source/WebCore/page/FrameView.cpp:907
#52 0x00007fb81df52955 in WebCore::FrameView::updateLayoutAndStyleIfNeededRecursive (this=0x7fb7b5208dc0)
    at Source/WebCore/page/FrameView.cpp:2368
#53 0x00007fb81d9bb33c in webkit_web_view_draw (widget=<optimized out>, cr=0x57d8060) at Source/WebKit/gtk/webkit/webkitwebview.cpp:744
#54 0x00000039173485f8 in _gtk_marshal_BOOLEAN__BOXED (closure=0x10ec000, return_value=0x7fff7ef25ba0, n_param_values=<optimized out>, 
    param_values=0x36b0c90, invocation_hint=<optimized out>, marshal_data=<optimized out>) at gtkmarshalers.c:85
#55 0x0000003917468630 in gtk_widget_draw_marshaller (closure=0x10ec000, return_value=0x7fff7ef25ba0, n_param_values=2, param_values=
    0x36b0c90, invocation_hint=<optimized out>, marshal_data=<optimized out>) at gtkwidget.c:802
#56 0x0000003b76c0e2ee in g_closure_invoke (closure=0x10ec000, return_value=0x7fff7ef25ba0, n_param_values=2, param_values=0x36b0c90, 
    invocation_hint=0x7fff7ef25b60) at gclosure.c:767
#57 0x0000003b76c1efba in signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=0x42af650, emission_return=0x7fff7ef25d00, 
    instance_and_params=0x36b0c90) at gsignal.c:3290
#58 0x0000003b76c2872b in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, 
    var_args=<optimized out>) at gsignal.c:2993
#59 0x0000003b76c28b12 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3040
#60 0x000000391747a23a in _gtk_widget_draw_internal (clip_to_size=1, cr=0x57d8060, widget=0x42af650 [EphyWebView]) at gtkwidget.c:5688
#61 _gtk_widget_draw_internal (widget=0x42af650 [EphyWebView], cr=0x57d8060, clip_to_size=1) at gtkwidget.c:5666
#62 0x000000391747a3c1 in gtk_widget_send_expose (widget=0x42af650 [EphyWebView], event=<optimized out>) at gtkwidget.c:5935
#63 0x00000039173484fc in gtk_main_do_event (event=0x7fff7ef25f10) at gtkmain.c:1797
#64 0x0000003916e33b5f in _gdk_window_process_updates_recurse (window=0x185e000 [GdkX11Window], expose_region=0x4cf57b0)
    at gdkwindow.c:3855
#65 0x0000003916e33aff in _gdk_window_process_updates_recurse (window=0x5923ea0 [GdkX11Window], expose_region=0x4cf57e0)

    at gdkwindow.c:3828
#66 0x0000003916e33aff in _gdk_window_process_updates_recurse (window=0x10eb7e0 [GdkX11Window], expose_region=0x5513870)
    at gdkwindow.c:3828
#67 0x0000003916e3312f in gdk_window_process_updates_internal (window=0x10eb7e0 [GdkX11Window]) at gdkwindow.c:4011
#68 0x0000003916e335a0 in gdk_window_process_all_updates () at gdkwindow.c:4142
#69 0x0000003916e33619 in gdk_window_update_idle (data=<optimized out>) at gdkwindow.c:3745
#70 0x0000003916e19d8f in gdk_threads_dispatch (data=0x52d4ac0) at gdk.c:741
#71 0x0000003b76042b6d in g_main_dispatch (context=0x10f1f30) at gmain.c:2440
#72 g_main_context_dispatch (context=0x10f1f30) at gmain.c:3013
#73 0x0000003b76043348 in g_main_context_iterate (context=0x10f1f30, block=<optimized out>, dispatch=1, self=<optimized out>)
    at gmain.c:3091
#74 0x0000003b7604398d in g_main_loop_run (loop=0x11a2150) at gmain.c:3299
#75 0x000000391734769d in gtk_main () at gtkmain.c:1358
#76 0x000000000042fe84 in main (argc=1, argv=0x7fff7ef275e8) at ephy-main.c:747
(gdb)
Comment 1 Martin Robinson 2011-05-01 00:31:55 PDT
Pretty sure this is a dupe. Feel free to undupe if I've been duped by a false dupe.

*** This bug has been marked as a duplicate of bug 48723 ***