Bug 55787 - WebKit uses multiple conflicting names to refer to the device scale factor
: WebKit uses multiple conflicting names to refer to the device scale factor
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Matthew Delaney
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-04 10:55 PST by Simon Fraser (smfr)
Modified: 2011-08-15 08:06 PDT (History)
8 users (show)

See Also:


Attachments
Clear up scale factor terminology (82.87 KB, patch)
2011-08-10 15:23 PDT, Adam Roben (:aroben)
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2011-03-04 10:55:53 PST
HTMLCanvasElement has a member called m_pageScaleFactor, which is computed from >page()->chrome()->scaleFactor(), and relates to HiDPI stuff.

Frame::pageScaleFactor() is related to zooming, and doesn't affect canvas resolution.

Confusion abounds.
Comment 1 Adam Roben (:aroben) 2011-08-10 15:23:44 PDT
Created attachment 103540 [details]
Clear up scale factor terminology
Comment 2 WebKit Review Bot 2011-08-10 15:25:56 PDT
Attachment 103540 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1

Source/WebKit/efl/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit/gtk/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit/haiku/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebCore/css/MediaQueryEvaluator.cpp:296:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/WebKit/qt/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit2/UIProcess/WebPopupMenuProxy.h:62:  The parameter name "rect" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit/mac/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit/win/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit/wx/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit2/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit/wince/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebKit/chromium/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Total errors found: 12 in 88 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Adam Roben (:aroben) 2011-08-10 15:27:21 PDT
Comment on attachment 103540 [details]
Clear up scale factor terminology

View in context: https://bugs.webkit.org/attachment.cgi?id=103540&action=review

>> Source/WebKit/chromium/ChangeLog:1
>> +2011-08-10  Adam Roben  <aroben@apple.com>
> 
> ChangeLog entry has no bug number  [changelog/bugnumber] [5]

I left out the bug number intentionally in all the non-WebCore ChangeLogs, since the bug is WebCore-specific. I could retitle the bug to be more generic and put it everywhere, I guess.
Comment 4 James Robinson 2011-08-10 15:29:01 PDT
I think people looking at their port's ChangeLogs only would appreciate that.
Comment 5 Adam Roben (:aroben) 2011-08-15 06:31:13 PDT
OK, I'm retitling this bug to represent the more general problem of there being too many names that mean "the scale factor of the display on which we're rendering". HTMLCanvasElement::m_pageScaleFactor is just one part of that problem. I'll add the bug title/URL to all the ChangeLogs and land this.
Comment 6 Adam Roben (:aroben) 2011-08-15 08:06:31 PDT
Fixed in r93040 and r93043.