Bug 55286 - XHTMLMP build broken after r78342
Summary: XHTMLMP build broken after r78342
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 55285 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-25 18:58 PST by gil
Modified: 2011-03-03 09:06 PST (History)
2 users (show)

See Also:


Attachments
webkitgtk build (deleted)
2011-02-25 18:58 PST, gil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description gil 2011-02-25 18:58:25 PST
Created attachment 83915 [details]
webkitgtk build

GEN    DerivedSources/WebCore/JSCSSImportRule.h
trol reaches end of non-void function
make[1]: *** [Source/WebCore/dom/libWebCore_la-Document.lo] Error 1
make[1]: Leaving directory `/usr/src/RPM/BUILD/webki  GEN    DerivedSources/WebCore/JSCSSMediaRule.h
  GEN    DerivedSources/WebCore/JSCSSPageRule.h


  CXX    Source/WebCore/dom/libWebCore_la-DeviceOrientation.lo
  CXX    Source/WebCore/dom/libWebCore_la-DeviceOrientationEvent.lo
  CXX    Source/WebCore/dom/libWebCore_la-Document.lo
Source/WebCore/dom/Document.cpp: In member function 'bool WebCore::Document::isXHTMLMPDocument() const':
Source/WebCore/dom/Document.cpp:4789:31: error: 'class WebCore::FrameLoader' has no member named 'writer'
Source/WebCore/dom/Document.cpp:4790:1: warning: control reaches end of non-void function
make[1]: *** [Source/WebCore/dom/libWebCore_la-Document.lo] Error 1
make[1]: Leaving directory `/usr/src/RPM/BUILD/webkit-1.3.12'
make: *** [all] Error 2

hello

i apologize if i come whenever i have a compilation issue.
i thank you for any suggestions you can give me in advance
in the attached file shows the full build WebKitGTK
with the employee to use.
i am using gcc version 4.5.2
gil
Comment 1 Martin Robinson 2011-02-28 13:26:42 PST
*** Bug 55285 has been marked as a duplicate of this bug. ***
Comment 2 Martin Robinson 2011-02-28 13:27:08 PST
What configure options are you passing or are you using the default options?
Comment 3 gil 2011-03-01 02:14:21 PST
hello
these are options passed to configure

CFLAGS="%{optflags} -DLIBSOUP_I_HAVE_READ_BUG_594377_AND_KNOW_SOUP_PASSWORD_MANAGER_MIGHT_GO_AWAY" \
%configure \
  --enable-geolocation \
  --enable-3d-transforms \
  --enable-channel-messaging \
  --enable-xhtmlmp \
  --enable-fast-mobile-scrolling \
  --enable-web-sockets \
  --enable-filters \
  --enable-coverage \
  --enable-introspection \
  --enable-mathml \
  --enable-video \
  --enable-jit \
  PYTHON=%{__python}

%{__python} has the value /usr/bin/python2.6

thanks
gil
Comment 4 Martin Robinson 2011-03-01 09:32:25 PST
This looks like some build issues with the XHTMLMP support. As a work-around until this is fixed, simply do not enable XHTMLMP. 

WebKitGTK+ does not yet have support for 3D transforms.
Comment 5 Martin Robinson 2011-03-03 09:06:02 PST
Committed r80246: <http://trac.webkit.org/changeset/80246>