Bug 55228 - REGRESSION (r79060): Timestamp is missing from tweets in twitter.
Summary: REGRESSION (r79060): Timestamp is missing from tweets in twitter.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Template Framework (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Critical
Assignee: Andy Estes
URL: http://twitter.com
Keywords: InRadar, NeedsReduction, Regression
Depends on: 49989
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-25 09:51 PST by nobody
Modified: 2011-03-07 23:27 PST (History)
5 users (show)

See Also:


Attachments
Patch (5.35 KB, patch)
2011-03-07 23:13 PST, Andy Estes
mitz: review+
aestes: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description nobody 2011-02-25 09:51:01 PST
Timestamp is missing from tweets in twitter.

Recent nightly builds fail to display the timestamp.

The latest nightly build for Mac, r79679, fails to display the timestamp.


Please note, the timestamp appears correctly in the latest version of Apple Safari for OS X 10.6.


Without the timestamp, it is no longer possible to determine the chronology of tweets, nor the URL of individual tweets.
Comment 1 Alexey Proskuryakov 2011-02-25 21:34:55 PST
<rdar://problem/9057871>
Comment 2 Andy Estes 2011-02-28 15:10:23 PST
Due to <http://trac.webkit.org/changeset/79060>.
Comment 3 Andreas Kling 2011-03-01 02:47:42 PST
Format used by Twitter: "Sun Feb 27 13:24:51 +0000 2011"
Comment 4 nobody 2011-03-07 11:14:08 PST
Apparently, not dependent on 49989.

Problem still exists (as of r80210).

Needs to be fixed...
Comment 5 Andy Estes 2011-03-07 11:27:36 PST
(In reply to comment #4)
> Apparently, not dependent on 49989.

Yes it is. This bug depends on the changeset landed for bug #49989 being in the tree. Creating the dependency relationship also helps bring the bug to the attention of the people who are most likely to fix it.
Comment 6 nobody 2011-03-07 14:05:54 PST
sorry! please pardon my misunderstanding-  i believed if the bug was dependent on #49989, and #49989 was fixed, then, accordingly, the Twitter problem would also be fixed. 

alas, the problem is not yet fixed. 

thanks for your patience and kind assistance. hope this helps.
Comment 7 Andy Estes 2011-03-07 23:13:56 PST
Created attachment 85023 [details]
Patch
Comment 8 Andy Estes 2011-03-07 23:27:45 PST
Committed r80542: <http://trac.webkit.org/changeset/80542>