Bug 55137 - Animate to Natural Value
Summary: Animate to Natural Value
Status: RESOLVED DUPLICATE of bug 16020
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Minor
Assignee: Nobody
Depends on:
Reported: 2011-02-24 05:36 PST by Chris Coyier
Modified: 2011-02-24 10:59 PST (History)
3 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Chris Coyier 2011-02-24 05:36:38 PST
It would be nice to be able to animate an element to it's auto value.

@-webkit-animation slideDown {
   0% { height: 0; }
   100% { height: auto; }

Like how a JavaScript library like jQuery can do   $("#thing").hide().slideDown(); and it slides down to the correct original natural height of that element.
Comment 1 Simon Fraser (smfr) 2011-02-24 10:59:12 PST

*** This bug has been marked as a duplicate of bug 16020 ***