RESOLVED FIXED Bug 54270
A little more encapsulation for MarkedBlock: Made all constants private so clients don't know whether allocations are fixed-sized or not
https://bugs.webkit.org/show_bug.cgi?id=54270
Summary A little more encapsulation for MarkedBlock: Made all constants private so cl...
Geoffrey Garen
Reported 2011-02-10 21:11:28 PST
A little more encapsulation for MarkedBlock: Made all constants private so clients don't know whether allocations are fixed-sized or not
Attachments
Patch (16.37 KB, patch)
2011-02-10 21:17 PST, Geoffrey Garen
sam: review+
Geoffrey Garen
Comment 1 2011-02-10 21:17:20 PST
WebKit Review Bot
Comment 2 2011-02-10 21:18:06 PST
Attachment 82098 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1 Source/JavaScriptCore/runtime/MarkedBlock.h:38: BLOCK_SIZE is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:40: BLOCK_SIZE is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:43: BLOCK_OFFSET_MASK is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:44: BLOCK_MASK is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:45: MINIMUM_CELL_SIZE is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:46: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] Source/JavaScriptCore/runtime/MarkedBlock.h:46: CELL_ARRAY_LENGTH is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:49: CELL_SIZE is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:51: SMALL_CELL_SIZE is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:52: CELL_MASK is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:53: CELL_ALIGN_MASK is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:54: BITS_PER_BLOCK is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/runtime/MarkedBlock.h:55: CELLS_PER_BLOCK is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 13 in 9 files If any of these errors are false positives, please file a bug against check-webkit-style.
Sam Weinig
Comment 3 2011-02-10 21:21:07 PST
Comment on attachment 82098 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=82098&action=review > Source/JavaScriptCore/runtime/JSGlobalData.cpp:90 > + char storage[64]; I think this wonky size could use a comment.
Geoffrey Garen
Comment 4 2011-02-10 21:34:21 PST
Note You need to log in before you can comment on or make changes to this bug.