Bug 5325 - webView:mouseDidMoveOverElement:modifierFlags: delegate method not being called correctly
Summary: webView:mouseDidMoveOverElement:modifierFlags: delegate method not being call...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 412
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2005-10-10 12:16 PDT by Rachael Worthington (cheers)
Modified: 2015-08-29 09:50 PDT (History)
3 users (show)

See Also:


Attachments
source for a reduced testcase (38.18 KB, application/octet-stream)
2005-10-10 13:19 PDT, Rachael Worthington (cheers)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rachael Worthington (cheers) 2005-10-10 12:16:34 PDT
The WebUIDelegate method webView:mouseDidMoveOverElement:modifierFlags: is not being called when 
different modifier keys are being held, but the mouse does not move. Best place to see this is in 
dashboard, where you hold option to display the close-widget in the upper left-hand corner. if you put 
your mouse on a dashboard widget and push option, no close-widget. move the mouse, and it appears.
Comment 1 Rachael Worthington (cheers) 2005-10-10 13:19:59 PDT
Created attachment 4298 [details]
source for a reduced testcase

this is a reduced version of the minibrowser example code that ONLY implements
the webView:mouseDidMoveOverElement:modifierFlags: and shows what I'm trying to
describe.
Comment 2 Joost de Valk (AlthA) 2006-02-13 15:57:06 PST
Reassigning to webkit-unassigned, to make sure more people see this.
Comment 3 Joost de Valk (AlthA) 2006-02-15 14:54:59 PST
Confirmed.
Comment 4 opendarwin 2007-10-07 10:30:23 PDT
In addition, the delegate method is not being called when the element changes under the unmoving mouse, for example, when a new web page is loaded in the webview.  According to the API, "When a user mouses over an element in a web view, various feedback is given. This method updates that feedback to reflect a new element or new modifier flags."  Thus, one would expect the method to be called when there is a new element under the mouse.

This WebKit bug seems to be the cause of the bug "Status bar text (link target) gets out of sync" <https://sourceforge.net/tracker/?func=detail&atid=753018&aid=1808808&group_id=142635> in Vienna (syndicated feed reader).
Comment 5 David Kilzer (:ddkilzer) 2007-10-07 17:45:46 PDT
<rdar://problem/5527217>
Comment 6 Alexey Proskuryakov 2007-10-07 21:24:45 PDT
(In reply to comment #4)
> In addition, the delegate method is not being called when the element changes
> under the unmoving mouse

See bug 4117, bug 15113.
Comment 7 David Kilzer (:ddkilzer) 2015-08-28 19:22:09 PDT
Please adopt the Modern WebKit APIs (WKWebVew). If this request is still valid to the Modern WebKit framework API, please file a new bug report.
Comment 8 opendarwin 2015-08-29 09:50:21 PDT
(In reply to comment #7)
> Please adopt the Modern WebKit APIs (WKWebVew). If this request is still
> valid to the Modern WebKit framework API, please file a new bug report.

Two questions:
1) Is there a method similar to webView:mouseDidMoveOverElement:modifierFlags: on WKWebView? I can't find one in the documentation.
2) Is WebView deprecated on the Mac?