Bug 52521 - REGRESSION(r75708): Breaks Qt build if mobility is not installed. (Requested by benjaminp on #webkit).
Summary: REGRESSION(r75708): Breaks Qt build if mobility is not installed. (Requested ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on: 52525
Blocks: 51249
  Show dependency treegraph
 
Reported: 2011-01-15 15:24 PST by WebKit Review Bot
Modified: 2011-01-15 19:18 PST (History)
6 users (show)

See Also:


Attachments
ROLLOUT of r75708 (25.18 KB, patch)
2011-01-15 15:24 PST, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2011-01-15 15:24:29 PST
http://trac.webkit.org/changeset/75708 broke the build:
Breaks Qt build if mobility is not installed. (Requested by benjaminp on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2011-01-15 15:24:51 PST
Created attachment 79080 [details]
ROLLOUT of r75708

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Benjamin Poulain 2011-01-15 15:27:29 PST
Comment on attachment 79080 [details]
ROLLOUT of r75708

The fix is not trivial. I revert for now.
Comment 3 WebKit Commit Bot 2011-01-15 15:42:00 PST
Comment on attachment 79080 [details]
ROLLOUT of r75708

Clearing flags on attachment: 79080

Committed r75885: <http://trac.webkit.org/changeset/75885>
Comment 4 WebKit Commit Bot 2011-01-15 15:42:07 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 WebKit Review Bot 2011-01-15 18:38:12 PST
http://trac.webkit.org/changeset/75885 might have broken GTK Linux 64-bit Debug
The following tests are not passing:
fast/js/regexp-charclass-crash.html