Bug 52106 - REGRESSION: CKEditor Source View Converts Markup, adds <p> tags
Summary: REGRESSION: CKEditor Source View Converts Markup, adds <p> tags
Status: RESOLVED DUPLICATE of bug 54978
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks: 9915
  Show dependency treegraph
 
Reported: 2011-01-07 23:40 PST by Mark Fischer
Modified: 2011-03-03 23:00 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Fischer 2011-01-07 23:40:03 PST
The nightly builds seem to be adding extra <p> tags when toggling between source view and markup, and then converts all markup to html entity codes.

1. Visit http://ckeditor.com/demo
2. Click the "Source" button once.
3. Click the "Source" button again.

This does not happen with Safari 5.0.3 6533.19.4
Comment 1 Kevin M. Dean 2011-01-11 14:46:25 PST
I see similar oddities with the TinyMCE editor as well when viewing the HTML source and using it's Cleanup Messy Code function. Works fine in Safari, but not in Webkit.

http://tinymce.moxiecode.com/tryit/full.php
Comment 2 Kevin M. Dean 2011-01-11 15:16:13 PST
The problem with both editors begins between Nightly r72487 and r72783.

It also affects PPC 10.5.8.
Comment 3 Alexey Proskuryakov 2011-01-20 17:06:29 PST
<rdar://problem/8896038>
Comment 4 Kevin M. Dean 2011-02-24 14:03:50 PST
Just posting to indicate that this problem is still around.
Comment 5 Ryosuke Niwa 2011-02-27 14:52:51 PST
Confirmed on nightly r79746.  This might be a duplicate of https://bugs.webkit.org/show_bug.cgi?id=54978.
Comment 6 Ryosuke Niwa 2011-02-27 14:54:57 PST
Could someone from CKEditor make a reduction?  The script on the page is very complicated and it'll be much easier for us to debug if we had a simpler html/javascript that demonstrates the cause of this bug.
Comment 7 Ryosuke Niwa 2011-03-03 23:00:03 PST
This indeed was a duplicate of 54978.  The bug no longer reproduces on the nightly r80210.

*** This bug has been marked as a duplicate of bug 54978 ***