Bug 50879 - Flaky Test: fast/preloader/script.html
Summary: Flaky Test: fast/preloader/script.html
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
: 51007 (view as bug list)
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2010-12-11 18:14 PST by WebKit Commit Bot
Modified: 2010-12-23 00:15 PST (History)
4 users (show)

See Also:


Attachments
Failure diff from bot (433 bytes, text/plain)
2010-12-15 16:45 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-16 19:21 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-17 14:20 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-17 20:50 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-18 15:27 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-18 19:23 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-20 06:00 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-20 10:59 PST, WebKit Commit Bot
no flags Details
Failure diff from bot (433 bytes, text/plain)
2010-12-20 11:35 PST, WebKit Commit Bot
no flags Details
Failure diff from eseidel-cq-sf (433 bytes, text/plain)
2010-12-20 19:21 PST, WebKit Commit Bot
no flags Details
Failure diff from eseidel-cq-sf (433 bytes, text/plain)
2010-12-21 01:38 PST, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2010-12-11 18:14:41 PST
This is an automatically generated bug from the commit-queue.
fast/preloader/script.html has been flaky on the commit-queue.

fast/preloader/script.html was authored by abarth@webkit.org.
http://trac.webkit.org/browser/trunk/LayoutTests/fast/preloader/script.html

The commit-queue just saw fast/preloader/script.html flake while processing attachment 76310 [details] on bug 50267.
Bot: eseidel-sf  Port: Mac  Platform: Mac OS X 10.6.4

The bots will update this with information from each new failure.

If you would like to track this test fix with another bug, please close this bug as a duplicate.
Comment 1 Eric Seidel (no email) 2010-12-13 23:45:02 PST
*** Bug 51007 has been marked as a duplicate of this bug. ***
Comment 2 WebKit Commit Bot 2010-12-14 01:26:07 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 75977 [details] on bug 50715.
Bot: eseidel-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 3 WebKit Commit Bot 2010-12-14 04:30:55 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 75707 [details] on bug 50571.
Bot: eseidel-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 4 WebKit Commit Bot 2010-12-14 04:47:23 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 75707 [details] on bug 50571.
Bot: eseidel-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 5 WebKit Commit Bot 2010-12-14 08:11:45 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76531 [details] on bug 51032.
Bot: eseidel-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 6 Adam Barth 2010-12-14 12:17:09 PST
Crazy.  Ok.  I'll look into making this less flaky.
Comment 7 WebKit Commit Bot 2010-12-14 23:03:26 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76597 [details] on bug 51012.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 8 WebKit Commit Bot 2010-12-15 16:45:00 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76633 [details] on bug 51046.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 9 WebKit Commit Bot 2010-12-15 16:45:04 PST
Created attachment 76711 [details]
Failure diff from bot
Comment 10 Adam Barth 2010-12-15 16:58:06 PST
How bizarre:

-script1.js has MIME type application/x-javascript
+script1.js has MIME type text/javascript
Comment 11 Eric Seidel (no email) 2010-12-15 17:00:42 PST
dumpResourceResponseMIMETypes() may just be racy.
Comment 12 Eric Seidel (no email) 2010-12-15 17:04:31 PST
layoutTestController.dumpResourceResponseMIMETypes() was added in http://trac.webkit.org/changeset/45274 by Brady/Sam.  They might know if it's known to be racy.  (I've added you both as CCs, but feel free to remove yourself if you don't have any insight.)
Comment 13 Eric Seidel (no email) 2010-12-15 17:31:27 PST
This seems to have only ever flaked on the sf cq bot.  I wonder if it could be a LaunchServices config issue which is somehow triggering this flakiness?
Comment 14 WebKit Commit Bot 2010-12-16 19:21:18 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76289 [details] on bug 50419.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 15 WebKit Commit Bot 2010-12-16 19:21:20 PST
Created attachment 76840 [details]
Failure diff from bot
Comment 16 WebKit Commit Bot 2010-12-17 14:20:44 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76898 [details] on bug 51156.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 17 WebKit Commit Bot 2010-12-17 14:20:47 PST
Created attachment 76909 [details]
Failure diff from bot
Comment 18 WebKit Commit Bot 2010-12-17 20:50:06 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76778 [details] on bug 51194.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 19 WebKit Commit Bot 2010-12-17 20:50:09 PST
Created attachment 76935 [details]
Failure diff from bot
Comment 20 Eric Seidel (no email) 2010-12-17 23:43:09 PST
I'm suspicious this might be that this test is *always* failing on that particular bot, and that this is getting reported due to bug 51272.
Comment 21 WebKit Commit Bot 2010-12-18 15:27:09 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76886 [details] on bug 51257.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 22 WebKit Commit Bot 2010-12-18 15:27:12 PST
Created attachment 76947 [details]
Failure diff from bot
Comment 23 WebKit Commit Bot 2010-12-18 19:23:42 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76832 [details] on bug 50905.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 24 WebKit Commit Bot 2010-12-18 19:23:45 PST
Created attachment 76949 [details]
Failure diff from bot
Comment 25 WebKit Commit Bot 2010-12-20 06:00:04 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 76894 [details] on bug 51112.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 26 WebKit Commit Bot 2010-12-20 06:00:07 PST
Created attachment 76992 [details]
Failure diff from bot
Comment 27 WebKit Commit Bot 2010-12-20 10:59:46 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 77006 [details] on bug 51338.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 28 WebKit Commit Bot 2010-12-20 10:59:48 PST
Created attachment 77014 [details]
Failure diff from bot
Comment 29 WebKit Commit Bot 2010-12-20 11:35:18 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 77006 [details] on bug 51338.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 30 WebKit Commit Bot 2010-12-20 11:35:21 PST
Created attachment 77016 [details]
Failure diff from bot
Comment 31 WebKit Commit Bot 2010-12-20 19:21:46 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 77056 [details] on bug 51360.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 32 WebKit Commit Bot 2010-12-20 19:21:49 PST
Created attachment 77069 [details]
Failure diff from eseidel-cq-sf
Comment 33 Eric Seidel (no email) 2010-12-20 19:23:58 PST
I believe this report is bogus, caused by bug 51272.  I'm writing a fix for bug 51272 right now.  Hopefully I'll have it upload this evening.

My apologies to all for the bug-noise.
Comment 34 WebKit Commit Bot 2010-12-21 01:38:01 PST
The commit-queue just saw fast/preloader/script.html flake while processing attachment 77090 [details] on bug 51272.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 35 WebKit Commit Bot 2010-12-21 01:38:03 PST
Created attachment 77095 [details]
Failure diff from eseidel-cq-sf
Comment 36 Eric Seidel (no email) 2010-12-23 00:15:28 PST
I believe the "flake" in this bot was just bug 51272.  The bots know how to re-open the bug if we see it again.