Bug 50179 - HTMLFormElement.elements doesn't include object element
Summary: HTMLFormElement.elements doesn't include object element
Status: RESOLVED DUPLICATE of bug 48821
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.whatwg.org/specs/web-apps/...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-29 13:40 PST by Yael
Modified: 2010-11-30 12:24 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yael 2010-11-29 13:40:43 PST
Per http://www.whatwg.org/specs/web-apps/current-work/multipage/forms.html#category-listed object elements should be listed in HTMLFormElement.elements.
Comment 1 Kenichi Ishibashi 2010-11-30 11:00:50 PST
Hi,

On https://bugs.webkit.org/show_bug.cgi?id=48821, I'm also working on making object elements to be a form associated element and it's almost ready to review. I'll post a trial patch soon. Have you started working on this?

(In reply to comment #0)
> Per http://www.whatwg.org/specs/web-apps/current-work/multipage/forms.html#category-listed object elements should be listed in HTMLFormElement.elements.
Comment 2 Yael 2010-11-30 12:21:40 PST
(In reply to comment #1)
> Hi,
> 
> On https://bugs.webkit.org/show_bug.cgi?id=48821, I'm also working on making object elements to be a form associated element and it's almost ready to review. I'll post a trial patch soon. Have you started working on this?

This was on my todo list, but I did not start working on it yet.

*** This bug has been marked as a duplicate of bug 48821 ***
Comment 3 Kenichi Ishibashi 2010-11-30 12:24:26 PST
(In reply to comment #2)
> This was on my todo list, but I did not start working on it yet.

Thanks your prompt response. I'm going to continue working on it, then:-)