Bug 49856 - DOM pull down menu leads to wrong information displayed.
Summary: DOM pull down menu leads to wrong information displayed.
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL: http://social.wakoopa.com/cowlitzron
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-19 20:18 PST by Ronald Clifford Buckman
Modified: 2010-12-30 22:08 PST (History)
0 users

See Also:


Attachments
The Wakoopa profile page in rekonq (webkit qt 2.0) (180.11 KB, image/png)
2010-11-19 20:18 PST, Ronald Clifford Buckman
no flags Details
A comparison of the Wakoopa page in rekonq (WebKit qt 2.0) and Midori (WebKit Gtk 1.2.5) (225.53 KB, image/png)
2010-11-19 20:34 PST, Ronald Clifford Buckman
no flags Details
The same page on rekonq and Arora both using Qt WebKit 2.0 (240.79 KB, image/png)
2010-12-12 22:34 PST, Ronald Clifford Buckman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Clifford Buckman 2010-11-19 20:18:19 PST
Created attachment 74464 [details]
The Wakoopa profile page in rekonq (webkit qt 2.0)

Under the "Usage" heading of this page is a pull down menu that reads "Per category".  When the menu is pulled down and the listing "Top used applications" is entered in WebKit Qt 4.7, the menu at the top of the page is redrawn and a list of applications that are used actively and in the background is drawn overlaying and sometimes being overlayed by other material which is originally on the page.  Which should happen and what does happen on Firefox and WebKit Gtk is that a chart showing how much the top used applications are used is displayed.
Comment 1 Ronald Clifford Buckman 2010-11-19 20:34:50 PST
Created attachment 74465 [details]
A comparison of the Wakoopa page in rekonq (WebKit qt 2.0) and Midori (WebKit Gtk 1.2.5)

The same bug is on every profile page of social.wakoopa.com
Comment 2 Ronald Clifford Buckman 2010-12-12 22:34:19 PST
Created attachment 76353 [details]
The same page on rekonq and Arora both using Qt WebKit 2.0

The bug is only in Konqueror on WebKit and rekonq but not in Arora.  It's a mystery to me why Konqueror-WebKit and rekonq has the bug but not Arora considering they all use the same layout engine.
Comment 3 Ronald Clifford Buckman 2010-12-30 21:52:21 PST
The proper version of the WebKit in Qt 4.7 is Qt WebKit 2.0.
Comment 4 Ronald Clifford Buckman 2010-12-30 22:08:05 PST
Rekonq depends on the package "libkdewebkit5", Arora does not.  Marked as Resolved - Invalid on the grounds that the problem is not with Qt WebKit 2.0 but rather with the KDE implementation of WebKit in Rekonq and Konqueror-WebKit.