Bug 48061 - REGRESSION(r70225): Build breakage on Leopard. (Requested by pfeldman on #webkit).
Summary: REGRESSION(r70225): Build breakage on Leopard. (Requested by pfeldman on #web...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 46973
  Show dependency treegraph
 
Reported: 2010-10-21 04:16 PDT by WebKit Review Bot
Modified: 2010-10-21 08:11 PDT (History)
5 users (show)

See Also:


Attachments
ROLLOUT of r70225 (74.96 KB, patch)
2010-10-21 04:16 PDT, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2010-10-21 04:16:12 PDT
http://trac.webkit.org/changeset/70225 broke the build:
Build breakage on Leopard. (Requested by pfeldman on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2010-10-21 04:16:54 PDT
Created attachment 71422 [details]
ROLLOUT of r70225

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Pavel Feldman 2010-10-21 04:19:41 PDT
@eric: cq landed build breakage.
Comment 3 WebKit Commit Bot 2010-10-21 04:37:41 PDT
Comment on attachment 71422 [details]
ROLLOUT of r70225

Clearing flags on attachment: 71422

Committed r70229: <http://trac.webkit.org/changeset/70229>
Comment 4 WebKit Commit Bot 2010-10-21 04:37:47 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Eric Seidel (no email) 2010-10-21 08:10:22 PDT
The cq only checks the build on one platform (Snow Leopard these days).  We could have it use the results of the EWS bots to help prevent breaking any builds.  However this is the first cq build break I've heard of in several months.  I believe the frequency is pretty rare.

Thanks for taking care of the rollout!
Comment 6 Eric Seidel (no email) 2010-10-21 08:11:03 PDT
Oh, we also once had code in sherrif-bot to have it automatically create rollouts when the cq caused a build break.  We could add that back if folks would find that behavior desirable.