Bug 47183 - Web Inspector: [Feature Request] Display Resources as a tree
Summary: Web Inspector: [Feature Request] Display Resources as a tree
Status: RESOLVED DUPLICATE of bug 47988
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-05 08:53 PDT by Alexei Masterov
Modified: 2010-11-13 06:16 PST (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexei Masterov 2010-10-05 08:53:46 PDT
Currently the resources panel shows all resources as a list, and there is no way to see which resource was loaded from which other resource.

What is the expected output?
==================
Show resources as a tree, with the page requested by the user as root.  It will make clear which resource was the cause of which other resource.
Comment 1 Timothy Hatcher 2010-10-05 08:59:55 PDT
Safari's Activity Monitor window does this. It is useful.
Comment 2 Alexander Pavlov (apavlov) 2010-11-13 06:16:25 PST

*** This bug has been marked as a duplicate of bug 47988 ***