Bug 47170 - Spatial Navigation: Focus selection when nothing is focused is wrong.
Summary: Spatial Navigation: Focus selection when nothing is focused is wrong.
Status: RESOLVED DUPLICATE of bug 49382
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Yael
URL:
Keywords:
Depends on:
Blocks: 46905
  Show dependency treegraph
 
Reported: 2010-10-05 05:39 PDT by Yael
Modified: 2010-11-11 09:22 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yael 2010-10-05 05:39:24 PDT
When using Spatial Navigation, tab index order should be ignored.
This problem is mostly visible when there is no focused node, e.g. after page load. The algorithm finds the node with the lowest tab index, instead of the first focusable node.

Here is an example:
    <a href="#">I am a</a><br>
    <div tabindex=3>I have tab index</div>
    <div tabindex=2>I have tab index</div>
    <div tabindex=1>I have tab index</div>
    <div tabindex=4>I have tab index</div>
 
I tested with Opera, and Opera finds the first <a> element, but WebKit finds the div with tab index 1.
Comment 1 Yael 2010-10-07 10:01:00 PDT
Title changed because fixing the issue is more than ignoring the "index" in tab-index.
A patch is coming soon.
Comment 2 Yael 2010-11-11 07:53:11 PST
This issue is addressed in the patch in https://bugs.webkit.org/show_bug.cgi?id=49382

*** This bug has been marked as a duplicate of bug 49382 ***
Comment 3 Ademar Reis 2010-11-11 09:22:55 PST
RESOLVED/DUPLICATED ==> no need to block bug 39121 anymore.