Bug 45527 - chromium fast/dom/replaceChild.html regression by r67182
Summary: chromium fast/dom/replaceChild.html regression by r67182
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 45526 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-10 03:23 PDT by Fumitoshi Ukai
Modified: 2011-01-28 14:37 PST (History)
6 users (show)

See Also:


Attachments
Patch (10.14 KB, patch)
2010-09-10 12:07 PDT, Eric Seidel (no email)
abarth: review+
commit-queue: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fumitoshi Ukai 2010-09-10 03:23:01 PDT
It looks like the following tests regressed in r67182:

 fast/dom/replaceChild.html = IMAGE
Comment 1 Pavel Podivilov 2010-09-10 04:00:51 PDT
*** Bug 45526 has been marked as a duplicate of this bug. ***
Comment 2 Eric Seidel (no email) 2010-09-10 11:21:39 PDT
OK.  Will investigate.  Please CC the reviewer and author of changes when you file regression bugs about checkins they made or approved. :)
Comment 3 Eric Seidel (no email) 2010-09-10 11:59:55 PDT
The new image matches minefield.  Seems the new image is right.  I don't see how the old image had a white square in it.
Comment 4 Eric Seidel (no email) 2010-09-10 12:02:59 PDT
Yes, the old behavior was definitely wrong.  Probably a repaint bug which I unintentionally fixed.

Notice how the border came from the iframe, and yet the iframe was supposed to be replaced!
http://trac.webkit.org/browser/trunk/LayoutTests/fast/dom/replaceChild.html
Comment 5 Eric Seidel (no email) 2010-09-10 12:07:23 PDT
Created attachment 67221 [details]
Patch
Comment 6 WebKit Commit Bot 2010-09-10 22:37:24 PDT
Comment on attachment 67221 [details]
Patch

Rejecting patch 67221 from commit-queue.

Failed to run "[u'/Users/eseidel/Projects/CommitQueue/WebKitTools/Scripts/svn-apply', u'--reviewer', u'Adam Barth', u'--force']" exit_code: 255
Parsed 3 diffs from patch file(s).
patching file LayoutTests/ChangeLog
Hunk #1 succeeded at 1 with fuzz 3.
patching file LayoutTests/platform/mac/fast/dom/replaceChild-expected.checksum
literal is only avaliable with the XS version at /Library/Perl/5.8.8/Compress/Zlib.pm line 9
BEGIN failed--compilation aborted at /Library/Perl/5.8.8/Compress/Zlib.pm line 9.
Compilation failed in require at /Users/eseidel/Projects/CommitQueue/WebKitTools/Scripts/VCSUtils.pm line 1670.

Full output: http://queues.webkit.org/results/3898376
Comment 7 Eric Seidel (no email) 2010-09-11 09:19:41 PDT
Committed r67299: <http://trac.webkit.org/changeset/67299>
Comment 8 WebKit Review Bot 2011-01-28 14:37:30 PST
http://trac.webkit.org/changeset/76977 might have broken Leopard Intel Release (Tests)