Bug 45299 - [Qt] Black screen is displayed for half of the screen when back key is pressed on a large page.
Summary: [Qt] Black screen is displayed for half of the screen when back key is presse...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: S60 Hardware S60 3rd edition
: P1 Normal
Assignee: Alexandra Santos
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-09-07 09:02 PDT by Alexandra Santos
Modified: 2010-09-24 09:58 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandra Santos 2010-09-07 09:02:56 PDT
STEPS TO REPRODUCE:

1.Launch the Browser.
2.Load xml.com
3.Load nytimes.com
4.As soon as the page is loaded press the back key from the toolbar 

ACTUAL RESULTS:
Black screen is displayed for half of the web page & content view also appears shrinked.

EXPECTED RESULTS:
Full content view should be displayed when back button is pressed.


NOTE: Full description of this issue can be found at: https://qtrequirements.europe.nokia.com/browse/BR-4534
Please don't hesitate to contact me if more detail is needed.
Comment 1 Suresh Voruganti 2010-09-07 10:16:03 PDT
Proposing it to QtWebkit 2.1 Top error.
Comment 2 Leonid Ebril 2010-09-07 10:50:24 PDT
This issue associated with the pagecache. This issue is not reproducible when PageCache is disabled.  Also, this issue is not reproducible on qtWebkit 2.0
Comment 3 Leonid Ebril 2010-09-15 04:26:10 PDT
This issue is not reprodusable on tilling version of the NokiaBrowser(Slava provided image).So, we pospnd working on this issue.
Comment 4 Leonid Ebril 2010-09-21 08:09:42 PDT
I could not reproduce this issue on the 10.1 wk 36, qt4.7, qtwebkit 2.1.
Comment 5 Suresh Voruganti 2010-09-24 09:58:26 PDT
Not reproducible on latest version.