Bug 42308 - More work on plug-in streams
Summary: More work on plug-in streams
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-14 17:42 PDT by Anders Carlsson
Modified: 2010-07-14 19:20 PDT (History)
4 users (show)

See Also:


Attachments
Patch (13.16 KB, patch)
2010-07-14 17:52 PDT, Anders Carlsson
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-07-14 17:42:59 PDT
More work on plug-in streams
Comment 1 Anders Carlsson 2010-07-14 17:52:59 PDT
Created attachment 61591 [details]
Patch
Comment 2 WebKit Review Bot 2010-07-14 17:53:54 PDT
Attachment 61591 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapePluginStream.h:36:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:60:  NPP_New is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:61:  NPP_Destroy is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:63:  NPP_NewStream is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:64:  NPP_DestroyStream is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePluginStream.cpp:80:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebKit2/WebProcess/Plugins/Netscape/NetscapePluginStream.cpp:90:  A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:151:  NetscapePlugin::NPP_NewStream is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:156:  NetscapePlugin::NPP_DestroyStream is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 9 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-07-14 18:03:48 PDT
Committed r63385: <http://trac.webkit.org/changeset/63385>
Comment 4 Daniel Bates 2010-07-14 18:34:21 PDT
This change broke the Apple Windows build bots. There are unresolved externals symbols:

See <http://build.webkit.org/builders/Windows%20Debug%20%28Build%29/builds/19414/steps/compile-webkit/logs/stdio>.
Comment 5 Anders Carlsson 2010-07-14 19:06:05 PDT
I checked in a speculative build fix, let's see if it's enough.