Bug 42287 - Add NetscapePlugin::NPP_ member functions for calling into the plug-in
Summary: Add NetscapePlugin::NPP_ member functions for calling into the plug-in
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-14 13:33 PDT by Anders Carlsson
Modified: 2010-07-14 13:49 PDT (History)
1 user (show)

See Also:


Attachments
Patch (4.51 KB, patch)
2010-07-14 13:34 PDT, Anders Carlsson
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-07-14 13:33:40 PDT
Add NetscapePlugin::NPP_ member functions for calling into the plug-in
Comment 1 Anders Carlsson 2010-07-14 13:34:40 PDT
Created attachment 61560 [details]
Patch
Comment 2 WebKit Review Bot 2010-07-14 13:36:50 PDT
Attachment 61560 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:55:  NPP_New is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:56:  NPP_Destroy is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:57:  NPP_SetWindow is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:58:  NPP_URLNotify is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:111:  NetscapePlugin::NPP_New is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:116:  NetscapePlugin::NPP_Destroy is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:121:  NetscapePlugin::NPP_SetWindow is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:126:  NetscapePlugin::NPP_URLNotify is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 8 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-07-14 13:49:53 PDT
Committed r63351: <http://trac.webkit.org/changeset/63351>