Bug 41254 - Web site compatibility: http://www.taharlev.com/ reloads forever
Summary: Web site compatibility: http://www.taharlev.com/ reloads forever
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL: http://www.taharlev.com/english.asp
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2010-06-26 11:46 PDT by Paul Menzel
Modified: 2012-08-16 03:09 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Menzel 2010-06-26 11:46:59 PDT
Accessing [1] reloads forever in Epiphany and Midori. Iceweasel can cope with it. In comparison the images are never displayed before reloading. I am using libwebkit-1.0-2 (1.2.1-2) in Debian Sid/unstable.

[1] http://www.taharlev.com/english.asp


PS: Bugzilla guessed my OS incorrectly (Apple instead of GNU/Linux).
PPS: I do not know what version corresponds to 1.2.1-2. I chose 525.x.
Comment 1 Alexey Proskuryakov 2010-06-27 14:34:51 PDT
I cannot reproduce this with Safari 5 or with a local build of r61167.
Comment 2 Paul Menzel 2010-07-17 01:10:04 PDT
(In reply to comment #1)
> I cannot reproduce this with Safari 5 or with a local build of r61167.

WebKit in Debian Sid/unstable was upgraded to 1.2.3 [1] and I can still reproduce this problem.

[1] http://blog.kov.eti.br/?p=116
Comment 3 Paul Menzel 2010-07-17 01:29:07 PDT
I reported this problem as #589380 in the Debian BTS [2].

[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=589380
Comment 4 Gustavo Noronha (kov) 2010-07-17 14:40:16 PDT
This sounds sooo much like one more instance of a site that reloads when the webview is resized, thus firing a resize DOM event (which in webkitgtk+ unfortunately happens when scrollbars are added to the main frame, because the scrollbars come from the parent widget, not from the webview).
Comment 5 Paul Menzel 2010-09-13 15:22:49 PDT
Just as an updated. I am still experiencing this with WebKit 1.2.4-1 in Debian Sid/unstable.
Comment 6 Paul Menzel 2010-10-20 03:26:09 PDT
Another update. I am still experiencing this with WebKit 1.2.5-1 in Debian Sid/unstable [1].

PS: I am setting the version to 528+, since that the Debian Developer opened #44681 with the same version.

[1] http://packages.debian.org/changelogs/pool/main/w/webkit/webkit_1.2.5-1/changelog#versionversion1.2.5-1
Comment 7 Paul Menzel 2012-08-16 03:09:51 PDT
Testing this today with

    libwebkit-1.0-2               1.2.7-3
    midori                        0.4.6+530-1
    libwebkitgtk-3.0-0            1.8.1-3.1

I cannot reproduce this anymore and the site loads fine. I forgot to test this with WebKit 1.2.6 or an earlier WebKitGTK+ release, since in the Debian BTS report Gustavo wrote that this is a WebKitGTK+ problem [1].

Changing the status to »RESOLVED«, »FIXED« hoping that this was a code fix and not that the site was changed. ;-)

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=589380#16