RESOLVED FIXED Bug 41226
Flesh out injected bundle code for WebKitTestRunner
https://bugs.webkit.org/show_bug.cgi?id=41226
Summary Flesh out injected bundle code for WebKitTestRunner
Sam Weinig
Reported 2010-06-25 14:21:59 PDT
Flesh out injected bundle code for WebKitTestRunner and add a basic LayoutTestController implementation.
Attachments
patch (32.35 KB, patch)
2010-06-25 14:25 PDT, Sam Weinig
andersca: review+
Sam Weinig
Comment 1 2010-06-25 14:25:00 PDT
WebKit Review Bot
Comment 2 2010-06-25 14:29:44 PDT
Attachment 59795 [details] did not pass style-queue: Failed to run "['WebKitTools/Scripts/check-webkit-style', '--no-squash']" exit_code: 1 Last 3072 characters of output: rrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:54: InjectedBundlePage::_didStartProvisionalLoadForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:59: InjectedBundlePage::_didReceiveServerRedirectForProvisionalLoadForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:64: InjectedBundlePage::_didFailProvisionalLoadWithErrorForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:69: InjectedBundlePage::_didCommitLoadForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:74: InjectedBundlePage::_didFinishLoadForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:79: InjectedBundlePage::_didFailLoadWithErrorForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:84: InjectedBundlePage::_didReceiveTitleForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:89: InjectedBundlePage::_didClearWindowForFrame is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/LayoutTestController.h:32: Alphabetical sorting problem. [build/include_order] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:26: Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted. [build/include_order] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:46: InjectedBundle::_didCreatePage is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:51: InjectedBundle::_willDestroyPage is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:56: InjectedBundle::_didRecieveMessage is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 27 in 9 files If any of these errors are false positives, please file a bug against check-webkit-style.
Sam Weinig
Comment 3 2010-06-25 15:35:26 PDT
Landed in r61906.
Note You need to log in before you can comment on or make changes to this bug.