Bug 37491 - "enableSuddenTermination has been invoked more times than necessary" log message after calling the Debugger() on mail.ru
Summary: "enableSuddenTermination has been invoked more times than necessary" log mess...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 420+
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://www.mail.ru
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-04-12 23:09 PDT by Mikhail
Modified: 2010-04-16 09:42 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail 2010-04-12 23:09:31 PDT
Overview:
"enableSuddenTermination has been invoked more times than necessary" log message appears after "Debugger()" console message on http://www.mail.ru/ + loosing keyboard focus from window.

Steps to Reproduce:

1. Open TextEdit?
2. Open Safari (Google search is my home page)
3. Navigate to  http://www.mail.ru
4. Console message: "com.apple.WebKit?.PluginAgent?[5932] Debugger() was called!"
5. Switch to TextEdit? and type something
6. Switch back to Safari window
7. Cmd+Q

Actual Results:
Log message appears (twice, but with the same timestamp):
"PM Safari[5969] -[NSProcessInfo enableSuddenTermination] has been invoked more times than necessary to balance invocations of -[NSProcessInfo disableSuddenTermination]. Ignoring."

Expected Results: no log message

Build Date & Platform:

I have found it on Mac OS X 10.6.3, Safari 4.0.5 (6531.22.7). Has not seen it before, but I have never check this.

Additional Information: 

I can not reproduce it without steps 5,6. But log message will also occur if steps 5 will be replaced to "Switch to finder and rename some directory".
Comment 1 Alexey Proskuryakov 2010-04-13 15:55:57 PDT
I don't expect the Debugger() message to be really related - it's just something Flash prints out sometimes.
Comment 2 Alexey Proskuryakov 2010-04-13 15:56:26 PDT
<rdar://problem/7860418>
Comment 3 Alexey Proskuryakov 2010-04-15 17:33:28 PDT
I can't reproduce this. Could you please describe this in more detail? Specifically,
- does this happen on other sites besides mail.ru,
- how you switch between application (Cmd+Tab or clicking in their windows),
- how you navigate to mail.ru,
- whether you wait for page loading to finish before going to TextEdit,
- whether this happens if you set home page to a blank one.

Does this happen if you log in using a guest account?

Do you have any "Safari enhancers" or "extensions" installed?
Comment 4 Mikhail 2010-04-15 18:59:59 PDT
(In reply to comment #3)
> I can't reproduce this. Could you please describe this in more detail?

Any help from me. You can also contact me directly using Skype.

One comment before answering the questions:
1. I has not been able to reproduce this issue using WebKit r57509 (13 April 2010).

2. There is the video regarding this issue:  http://magic.mactelabs.com/shared/safari_issue_37491.mov.zip

> Specifically,
> - does this happen on other sites besides mail.ru,

I has not been able to reproduce it on www.apple.com/startpage/, www.google.com.
I suppose that it something flash-related.

> - how you switch between application (Cmd+Tab or clicking in their windows),

By clicking on their windows (I did not check "Cmd+Tab").

> - how you navigate to mail.ru,

1. Click into Safari adress bar
2. Enter "mail.ru" or "www.mail.ru"
3. Press "Enter"

> - whether you wait for page loading to finish before going to TextEdit,

Website loading has been complete, full webpage has been loaded. 

> - whether this happens if you set home page to a blank one.

Yes, same results if empty page is home one.


> 
> Does this happen if you log in using a guest account?

Yes.

> 
> Do you have any "Safari enhancers" or "extensions" installed?

All "add-ons" has been removed and I have been able to reproduce it even after restarting Mac.
Comment 5 Alexey Proskuryakov 2010-04-16 09:42:04 PDT
Thanks! I can now reproduce this with shipping Safari/WebKit 4.0.5, but not with ToT.

Since this no longer happens with ToT, resolving as WORKSFORME.