Bug 37324 - [Qt] tst_QWebPage::createPlugin() fails
Summary: [Qt] tst_QWebPage::createPlugin() fails
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All Linux
: P1 Blocker
Assignee: Robert Hogan
URL:
Keywords: Qt
Depends on:
Blocks: 35784
  Show dependency treegraph
 
Reported: 2010-04-09 03:03 PDT by Simon Hausmann
Modified: 2010-04-26 03:15 PDT (History)
2 users (show)

See Also:


Attachments
Patch (9.37 KB, patch)
2010-04-20 14:19 PDT, Robert Hogan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Hausmann 2010-04-09 03:03:15 PDT
Reproducible on Linux/X11:

FAIL!  : tst_QWebPage::createPlugin() Compared values are not the same
   Actual (newPage->calls.count()): 1
   Expected (0): 0
   Loc: [/home/shausman/src/webkit/trunk/WebKit/qt/tests/qwebpage/tst_qwebpage.cpp(531)]
Comment 1 Andreas Kling 2010-04-09 03:54:26 PDT
This regression is caused by https://bugs.webkit.org/show_bug.cgi?id=32196
Comment 2 Simon Hausmann 2010-04-19 18:36:28 PDT
Robert, any ideas? :)
Comment 3 Robert Hogan 2010-04-20 11:59:43 PDT
(In reply to comment #2)
> Robert, any ideas? :)

Guilty as charged. The test is now invalid:


    // plugins not enabled by default, so the plugin shouldn't be loaded
    m_view->setHtml(QString("<html><body><object type='application/x-qt-plugin' classid='pushbutton' id='mybutton'/></body></html>"));
    QTRY_COMPARE(loadSpy.count(), 1);
    QCOMPARE(newPage->calls.count(), 0);

    m_view->settings()->setAttribute(QWebSettings::PluginsEnabled, true);

OK to remove it presumably.
Comment 4 Robert Hogan 2010-04-20 14:19:49 PDT
Created attachment 53879 [details]
Patch

Updated Docs too..
Comment 5 Robert Hogan 2010-04-25 00:24:06 PDT
Landed as r58112
Comment 6 Simon Hausmann 2010-04-26 03:13:09 PDT
<cherry-pick-for-backport: r58112>
Comment 7 Simon Hausmann 2010-04-26 03:15:30 PDT
Revision r58112 cherry-picked into qtwebkit-2.0 with commit 87a4fa8d64160f9c7fc6b7600c22f58ac81002b9