Bug 3711 - Displayed PDF have limited options in contextual menu
Summary: Displayed PDF have limited options in contextual menu
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 412
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: John Sullivan
URL:
Keywords:
Depends on:
Blocks: 59727
  Show dependency treegraph
 
Reported: 2005-06-25 12:58 PDT by Hanspeter Schaub
Modified: 2011-04-28 12:46 PDT (History)
2 users (show)

See Also:


Attachments
patch to always include PDF items for older executables (4.52 KB, patch)
2005-07-01 14:10 PDT, John Sullivan
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hanspeter Schaub 2005-06-25 12:58:57 PDT
When viewing PDF in the latest builds (6/25/05), there are only very few options available in the 
contextual menu.  In particular, the "View in Preview" option has been removed?  I'm running Safari 2.0 
with the lastest nightly webkit build.
Comment 1 Chris Petersen 2005-06-26 09:49:28 PDT
Confirming this issue with TOT Webkit (6/26). The contextual menu that is normally used for viewing PDF 
is not displayed. I get a generic contextual menu that contains Back, Reload, Save Page as, and Print Page.
Comment 2 Chris Petersen 2005-06-26 09:51:52 PDT
John:

Can you confirm this on TOT ?
Comment 3 John Sullivan 2005-06-26 11:12:26 PDT
When I changed WebKit to use the standard context menu delegate mechanism for the PDF context menu, 
this changed what appears in the context menu for Safari. The next Safari release will take advantage of 
this change in the way the PDF context menu works, but the current Safari release ends up not showing 
the PDF-specific items.

Darin, do you think we need to do something about this? I can imagine some hideous hack where WebKit 
somehow determines that it is running under Safari and that Safari isn't putting the PDF-specific items 
into the context menu, and forcing them in somehow. I'd rather not implement such a hack though.
Comment 4 Darin Adler 2005-06-26 21:53:25 PDT
I don't think a Safari-specific hack is a great idea, but if there's anything we can do to help the old Safari 
do the right thing that might also help other applications, that would be great.

Also, there's going to be a long time where WebKit developers outside Apple are going to be using that 
old Safari with new WebKit, so if there's something straightforward we can do, we should, even if we 
ultimately don't ship it. If necessary we could even add a preprocessor define that generates a WebKit for 
better compatibility with old Safari.
Comment 5 John Sullivan 2005-07-01 14:10:08 PDT
Created attachment 2738 [details]
patch to always include PDF items for older executables
Comment 6 Darin Adler 2005-07-01 14:38:12 PDT
Comment on attachment 2738 [details]
patch to always include PDF items for older executables

Looks cool, r=me.
Comment 7 John Sullivan 2005-07-01 14:47:37 PDT
I found a non-Safari-specific solution that isn't *too* hacky. Hanspeter, please verify that this works for 
you.
Comment 8 Hanspeter Schaub 2005-07-01 16:17:05 PDT
Seems to work find in the "old" version of Safari in Tiger.  I see the previous contextual menu added after 
the default items.

(In reply to comment #7)
> I found a non-Safari-specific solution that isn't *too* hacky. Hanspeter, please verify that this works for 
> you.
Comment 9 John Sullivan 2005-07-01 16:28:38 PDT
Since the originator has agreed that the problem is fixed, I'm changing this to VERIFIED.