Bug 36689 - new-run-webkit-tests should not complain about unexpected passes or failures for image tests when running w/ no pixel tests turned off
Summary: new-run-webkit-tests should not complain about unexpected passes or failures ...
Status: RESOLVED DUPLICATE of bug 36771
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Dirk Pranke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-26 18:30 PDT by Dirk Pranke
Modified: 2010-03-29 15:00 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Pranke 2010-03-26 18:30:39 PDT
Currently pixel tests are enabled in new-run-webkit-tests, and if you run w/ pixel tests disabled, any test expected to fail with IMAGE results will be reported as an unexpected pass (and any test expected to fail as IMAGE+TEXT presumably would fail w/ unexpected TEXT failure).

new-run-webkit-tests should be smart enough to not complain about this.
Comment 1 Dirk Pranke 2010-03-29 15:00:20 PDT

*** This bug has been marked as a duplicate of bug 36771 ***